I am running Fedora 12 and I've setup a partition separate from my root partition to keep shared files and home directories.

Now, I've been having permission issues where it says the user cannot chdir into their home directory (/files/home/*). Now, I fixed this originally by chmodding / to 0755 and the home directories also to 0755. And yes, the user is the owner:group of their home directory.

Now get this, I didn't change a thing, rebooted, everything still works. Great, right? I boot the server up a day later, and now same ol issue. This is a home server that wasn't on at all at any point in between the working state and non-working state. Also, nothing else was modified.

Any ideas?


== edit ==

Ok. So I've narrowed it down to an SELinux issue. If I run "setenforce 0" everything is fine. However, I'd prefere to keep SELinux enabled. Is there anyway around this?

2 Answers 2


If SELinux is denying access, you can userestorecon to reset the security label on the home partition mount point and home directories according to their basic Unix permissions:

sudo restorecon -v /files/home /files/home/*

More information: SELinux Troubleshooting: Top Three Causes of Problems

On systems running SELinux, all processes and files are labeled with a label that contains security-relevant information. This information is called the SELinux context. If these labels are wrong, access may be denied. If an application is labeled incorrectly, the process it transitions to may not have the correct label, possibly causing SELinux to deny access, and the process being able to create mislabeled files.

A common cause of labeling problems is when a non-standard directory is used for a service. [...]


Try this (it solves my prob always): sudo chown -R username:group /home/username
Recursive reown. Just a hunch.

By the way: /files/home/* < What the heck?

  • It's a partition so if I ever change distros, homes are backed up on a separate partition. I knew someone would say "what the heck" ;).
    – Tres
    Jun 9, 2010 at 15:16
  • BTW, thanks for the answer, can't upvote you cause of my rep. However, I have tried this, turns out it's SELinux.
    – Tres
    Jun 9, 2010 at 15:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .