2

I've been stumped trying to run Nextcloud via docker for the past few weeks. I've tried using ownyourbits/nextcloudpi, nextcloud, and the example docker-compose scripts provided by the Nextcloud team, but they will all complain about some file being unexecutable. However, I do have other containers successfully running.

Since this happens with multiple containers, I think it must be a problem with my system. If I exec into the container, I'm able to use apt to reinstall the affected files and get things working. However, this will be undone when new containers are pulled.

Trying to example the files will give errors like these: objdump: /usr/bin/jq: file format not recognized. The affected programs work fine on my docker host.

It almost appears that binaries are being corrupted as they're being pulled from dockerhub... is this possible? What else can I do to troubleshoot this?

I'm running Ubuntu Server 19.10 x86_64:

chase@chase-server:~$ uname -a
Linux chase-server 5.3.0-24-generic #26-Ubuntu SMP Thu Nov 14 01:33:18 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
New contributor
Chase is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Sorry about that, added to the bottom of the OP – Chase Dec 2 at 22:01
  • I've tried multiple images, but the latest I'm having trouble with is ownyourbits/nextcloudpi. I create the container with docker create -p 443:443 -p 80:80 -v ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi nextcloud.chaselau.me. using file on jq reads: /usr/bin/jq: data – Chase Dec 2 at 22:44
  • That's definately wrong - pastebin.com/H3eQw61v... can you try removing the image and re-acquiring it? – Attie Dec 2 at 23:24
  • Unfortunately, I've tried that quite a few times. Do you know of any way docker would link things like jq from a container with the host system? I can't think of a reason why the library would be pulled down wrong... – Chase Dec 2 at 23:45
  • Did you follow the steps I took in the pastebin dump? Docker should be pretty good a ensuring integrity of retrieved images, however it may be possible that your local storage is falling... have you had any other problems? – Attie Dec 2 at 23:53

Your Answer

Chase is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.