1

I have a Logitech B170 Wireless mouse which I use with my Windows 10 Laptop. I am not a fan of the scroll wheel, so I have never used the scroll wheel in this mouse or any other mouse ever. But there is a website I started using recently which uses scroll wheel for some features.

I just tried the scroll wheel on my mouse for the first time & nothing happens when I use it. I don't know if may be I have changed some settings when I first installed the mouse. I couldn't find any settings for enabling/disabling scroll wheel in Control Panel Mouse Settings either.

This is the Device Manager screenshot

This is the device manager screenshot

These are the mouse wheel settings mouse wheel settings

How do I get the scroll wheel to work?

8
  • Does the scroll-wheel work when booting in Safe mode? – harrymc Dec 16 '19 at 11:27
  • Haven't tried it. Will try once I get home. – user93353 Dec 16 '19 at 11:31
  • @harrymc - how do I test in Safe Mode? As I said before I have never used the Scroll Wheel - I don't which application I can test it with - I want to use it on website, but I won't be able to access the website in SafeMode – user93353 Dec 16 '19 at 12:06
  • A text-editor is a good test. The number of scroll-lines (25) is a bit high. – harrymc Dec 16 '19 at 12:30
  • @harrymc - scroll wheel didn't work in safe mode either. – user93353 Dec 17 '19 at 2:50
1

Had the same problem with a white Logitech PS/2 optical tilt wheel Mouse on a fresh install of windows 10 64-bit. Also had multiple mouse devices connected. Solved by: Install setpoint from Logitech website https://support.logi.com/hc/en-us/articles/360025141274 (SetPoint6.69.126_64.exe or SetPoint6.69.126_32.exe depending on your OS). Then, open setpoint settings from the system tray and go to tools tab from top right to select 'Install PS/2 Driver' button. Restarted the desktop and the corresponding mouse's driver provider in device manager, shows logitech instead of microsoft and now works absolutely fine. You probably do not need the ps/2 driver but check if your mouse shows up in Setpoint. IF not, try updating the ps/2 driver (whichever company) of the last mouse which shows up in your screen shot.

0

Have you tried using scroll on other websites or application? Maybe that website is having a bug.

  1. You can try disassemble mouse and see if there is dust or hair and clean it with brush or canned air.

  2. You can check regedit and see values there. Go to:

HKEY_CURRENT_USER\Control Panel\Desktop

and locate:

WheelScrollChars and WheelScrollLines

Then check the values if they are the same as in the Control Panel.

  1. Try switching USB port on your laptop.

  2. Try changing values in the Control Panel and see what happens.

  3. The last thing to try, take mouse over to a friends house and plugin in his PC or laptop, and see if that resolves the problem. If that doesn't help, then it's faulty mouse.

2
  • Tried using the scroll wheel at other sites. Doesn't work. Different USB port also doesn't work. Registry values are the same. – user93353 Dec 4 '19 at 8:20
  • Have you tried other mouse? – Manojlo Dec 17 '19 at 9:31
0

This is a PS2 mouse, so the scroll-wheel should have worked with the Windows generic driver. The fact that Mouse Properties includes a Wheel tab means that Windows has identified the mouse as indeed having a scroll-wheel.

In spite of this, the scroll-wheel does not work, and on more than one computer.

There are two possibilities:

  1. A hardware problem with this specific mouse
  2. A missing driver.

I don't believe in the second option, but please let us know what is the exact model of this mouse, to check if it needs a driver.

The first option can be tested by trying out another scroll-wheel mouse of another model.

4
  • The mouse model is in the title - Logitech B170 – user93353 Dec 18 '19 at 12:31
  • I haven't tried it on a second computer yet - I am currently traveling & hence won't be able to try it on another computer for atleast a couple of weeks. – user93353 Dec 18 '19 at 12:32
  • The computer is a laptop & the mouse is wireless & connected through bluetooth on USB – user93353 Dec 18 '19 at 12:32
  • I looked everywhere except the title ... There is no driver for this mouse. The only download that might pertain is Logitech Options, perhaps worth trying. – harrymc Dec 18 '19 at 13:20
0

Open the Registry Editor. To do this, click on WIN + R to open the Run app, type in the Open: regedit field and press Enter. Go to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt

Edit the StartValue value (double click on it) setting it to 1 and click OK. If it does not exist, create a new DWORD value. Right click in an empty area and choose New > DWORD Value (32 Bit). Restart the computer, disconnecting all USB keyboards and mice and leaving only the PS/2 devices connected.

3
  • I don't have a key named StartValue inside i8042prt. I do have one named Start (DWORD) - is that what you are referring to or should I create a new one named StartValue – user93353 Dec 19 '19 at 11:02
  • You have to create a new one named StartValue. – Riccardo La Marca Dec 19 '19 at 11:15
  • Tried this. Didn't work – user93353 Dec 20 '19 at 3:22
-1

You have probably gone and bought a different mouse already to solve your wheel problem but for the benefit of many others who probably will agonize over the same or similar problem, here's what I found:

My equipment: ACER laptop and Logitech wireless mouse (specific model probably irrelevant). My OS: Windows 10 the Terrible. Browser: Chrome the Crasher.

Problem encountered: After last massive Windows update download, mouse wheel would only move pointer in Office apps and in local drive directories. On web pages the wheel just sat there scorning me - did not move at all.

Investigation results:

  1. You won't find a fix for it in Chrome Browser SETTINGS.
  2. You must ignore Logitech troubleshooting as it fixes nothing.
  3. Messing with ACER "device properties" via any hardware access route does not fix the problem; only adds frustration.
  4. Windows 10 is the culprit. Last Microsoft download (that sneaks around in background every month) must have reset mouse settings to zero original default (or something like that).

Conclusion: To make my mouse wheel move the pointer in a scroll-like fashion on web pages I had to go into the WINDOWS10 mouse settings as follows:

  1. Find the start button on your computer (usually bottom left) and click on it.
  2. Scroll down to that settings, open it, then Device and Mouse buttons on next screens.
  3. If you have Windows 10 installed on your PC you will now see a menu that allows you to establish how many lines you want your mouse wheel to scroll. Note this is not an ACER or LOGITECH or CHROME thing, it is strictly a WINDOWS thing even if the screen denies it. The above solution worked for me; hope so for others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.