-1

I want to install Parallels Tools on a Kali Linux virtual machine, but I can't.

Parallels Tools installer tells me that I have to install "printer-driver-postscript-hp" but when I try to install it manually it says: "is already the newest version". So the driver is installed.

I'm running Parallels Desktop version 14 and Kali Linux 2019.4 and I have this in my /etc/apt/sources.list

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line 
deb-src http://http.kali.org/kali kali-rolling main contrib non-free

I don't want to update Parallels Desktop to 15, but I think that this shouldn't be a problem.

I've tried these steps

  1. apt-get clean
  2. apt-get update
  3. apt-get upgrade -y
  4. apt-get dist-upgrade -y
  5. restart
  6. install the parallel tools by running the installer
New contributor
TudorP is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Try exactly following the documentation Parallels Tools installation in Kali Linux Virtual machines as you are missing some steps. – lx07 Dec 3 at 14:23
  • That's where I started and it didn't worked – TudorP 2 days ago
  • Did you run apt-get install dkms kpartx printer-driver-postscript-hp after running apt-get dist-upgrade -y? Can you edit question with results and also what error exactly you get from step 6. – lx07 2 days ago

Your Answer

TudorP is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.