0

I recently upgraded to openSUSE 15.1. However, since then I cannot connect to the internet via my Wifi.

Here is some info:

linux-cyur:~ # hwinfo --wlan
13: PCI 300.0: 0282 WLAN controller                             
  [Created at pci.386]
  Unique ID: y9sn.DVcPkv35sTA
  Parent ID: Z7uZ.9o8gP8qzJWF
  SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Intel Dual Band Wireless-AC 8265"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x24fd "Wireless 8265 / 8275"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x1010 "Dual Band Wireless-AC 8265"
  Revision: 0x78
  Driver: "iwlwifi"
  Driver Modules: "iwlwifi"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xf1100000-0xf1101fff (rw,non-prefetchable)
  IRQ: 282 (no events)
  HW Address: 44:03:2c:6a:ad:e2
  Permanent HW Address: 44:03:2c:6a:ad:e2
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v00008086d000024FDsv00008086sd00001010bc02sc80i00"
  Driver Info #0:
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #1 (PCI bridge)
linux-cyur:~ # systemctl status network.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Tue 2019-12-03 18:28:10 CET; 26min ago
     Docs: man:NetworkManager(8)
 Main PID: 1062 (NetworkManager)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           ├─1062 /usr/sbin/NetworkManager --no-daemon
           └─3134 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-wlan0.pid -lf /var/lib/NetworkManager/dhclient-3da5a845-50d7-4a36-8014-c24f479936c5-wlan0.lease -cf /var/lib/NetworkManager/dhclient-wlan0.conf wlan0

Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3536] dhcp4 (wlan0):   domain name 'fritz.box'
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3537] dhcp4 (wlan0): state changed unknown -> bound
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3553] device (wlan0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3560] device (wlan0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3563] device (wlan0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3564] manager: NetworkManager state is now CONNECTED_LOCAL
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3612] manager: NetworkManager state is now CONNECTED_SITE
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.3614] policy: set 'betzonline' (wlan0) as default for IPv4 routing and DNS
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: nisdomainname: you must be root to change the domain name
Dec 03 18:28:57 linux-cyur NetworkManager[1062]: <info>  [1575394137.4799] device (wlan0): Activation: successful, device activated.
linux-cyur:~ # ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 44:03:2c:6a:ad:e2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.178.190/24 brd 192.168.178.255 scope global noprefixroute dynamic wlan0
       valid_lft 862443sec preferred_lft 862443sec
3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether a8:1e:84:f0:8d:28 brd ff:ff:ff:ff:ff:ff
linux-cyur:~ # ip route
default via 192.168.178.1 dev wlan0 proto dhcp metric 20600 
192.168.178.0/24 dev wlan0 proto kernel scope link src 192.168.178.190 metric 600
linux-cyur:~ # cat /etc/resolv.conf
### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
### Call "netconfig update -f" to force adjusting of /etc/resolv.conf.
search fritz.box
nameserver 192.168.178.1
linux-cyur:~ # ping www.google.com
ping: www.google.com: Name or service not known
linux-cyur:~ # ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=57 time=9.74 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=57 time=40.2 ms
...
linux-cyur:~ # nmcli g
STATE                  CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
connected (site only)  limited       enabled  enabled  enabled  enabled

What's more, I can connect to all 'NAT'ed hosts, e.g. my router. Also I temporarily disabled IPv6 (with IPv6 the problem was identical)

So, as I interpret the situation, I am able to speak to hosts in my lan, but cannot connect to hosts outside my lan (internet) when I just use hostnames, not IP addresses (ping 8.8.8.8 worked but ping www.google.com didn't). Also adding 8.8.8.8 to my resolv.conf didn't work as well. Completely removing resolv.conf and rebooting didn't work as well. So at the moment I have no idea, what is the reason for this problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.