0

I have a freshly installed Windows 10 PRO system and MS Office Home&Business 2019. I use a 4K monitor on an Nvidia GeForce GTX 750Ti graphics card (I downloaded the latest drivers from Nvidia).

My problem is that Office programs can start extremely small. That is especially the case with "new mail window" in Outlook. See print screen below:

enter image description here

The window is actually so small that I can hardly locate on the Desktop and change it's size. It's similar with other programs*, but not as severe as is the case with Outlook's New message window.

Each program I open it feels like the window should be bigger (and also it was bigger when I last used the program). Sometimes even when my monitor goes to sleep (and Windows is locked) the windows of the open programs are smaller when I log back in.

The problem is really frustrating (it's my work computer), because I spent 10% of my computer time resizing windows.

What could be the problem?

*I'm experiencing similar behaviour on my home computer (Windows Home, also 4K monitor), but I do not have Office installed so the problem is less severe...

**I do lot of remote deskop connecting with above mentioned computers (from "home" to "work"), if this is in any way relevant ?

  • After resizing the Office window, close it while holding the Control button, and it should remember the size for the next open of the same application. – harrymc Dec 3 at 20:56
  • tried it already. Only works till computer goes to sleep (locks) for the first time – TheMixy Dec 4 at 8:17
  • You could try in "Programs and Features" to right click Microsoft Office, select Change, and repair it using the Quick method, then Online if required. At worst, uninstall and install might help (if you can). Question: "similar behaviour on my home computer" - what is common between the two computers and which apps show this on the Home computer? – harrymc Dec 4 at 8:23
  • You can right-click Office application icons from Start menu > More > Open file location, right-click shortcut > select Properties, select the Compatibility tab, check the option Override high DPI scaling behavior, scaling performed by: Application. In later versions of Windows, you can need to click Change High DPI settings to find the option. You can also modify Program DPI setting to have a check. – Herb Gu Dec 4 at 9:23
  • @harrymc: since it's a fresh install of Office (on fresh install on Windows) I don't think a repair would do. The same is happening with my other programs' windows (i.e. Mozilla), just not as drastic as in my print screen above. The thing common between both computers is Windows 10 (one Pro other Home) and a 4K monitor - since my other computer doesnt have Office, I notice similar problem with Firefox after computer is going to sleeps (and I log back in)... – TheMixy Dec 4 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.