0

We use AutoCAD 2011 with the FlexNet License Server. The License Server is a Windows Server 2012R2 VM running on Hyper-V.

We are migrating our VMs from Microsoft Hyper-V to another hypervisor, EuroNAS eeVOS. The export from Hyper-V went without issue and the import into the new environment went without a glitch. All shares are the same. All drive letters internally are the same.

Originally, JMR-Project used to be a physical box, which I virtualized. The virtualization went without a hitch however long ago and all our users can access AutoCAD. No changes on the client were necessary from the physical box to the VM on Hyper-V. The computer names were kept the same.

I exported the AutoCAD FlexNet VM from Hyper-V and we imported the VM into EuroNAS eeVOS. That went without a hitch. All shares and drive letters are identical. I removed both VMs from the AD trust and added in the new VM to our AD domain.

The new VM appears fine, just I cannot get AutoCAD users to recognize the license server, even though the name is the same. Client computers got rebooted and the DNS cache emptied. The client computers can definitely ping the new license server VM. Opening File Explorer and going to the share works perfectly, so DNS cache is definitely not the issue. The license server uses the computer name, not IP address. Do not forget the original virtualization went without a hitch, which meant a new MAC address and new IP.

If I go through the process to switch back to the virtual machine on Hyper-V (remove both units from trust, shut down on EuroNAS eeVOS, and put the old VM back into the JMR AD trust), then the clients are fine. I went through the process several times now. I have looked at LMTools.exe and everything looks fine. The FlexNet License Service runs (Computer Management -> Services).

Thoughts?

  • What do you mean by 'recognize'? Do they fail to resolve the DNS address at all? Do they send packets but never receive replies? Do they get rejected by the server? Do they get a license but refuse to admit it? – grawity Dec 3 at 22:45
  • 1
    Also, does lmstat -a show the correct count of licenses available? As far as I know usually AutoCAD licenses are bound to MAC address. – grawity Dec 3 at 22:56
  • @grawity What I see is that when I have the new VM up and launch AutoCAD I get a dialog box asking for the server name or license file. I then tell it the server name (tried with and without the domain suffix) and then I get the exact same dialog back. There is no way to cancel out of that dialog box. I am forced to go to Task Manager and kill the process. – Sarah Weinberger Dec 3 at 23:43
  • @grawity I did not try lmstat -a and nor do I see lmstat in the C:\Program Files\Autodesk Network License Manager folder on the server or in the Autodesk folder on the client. The MAC thing makes sense, so I should give that a try. A support engineer with EuroNAS suggested that. My issue with that is that going from the physical box to the VM on Hyper-V did not cause this same issue and the MAC address definitely changed there. Maybe I got lucky then, not that I believe in "luck". – Sarah Weinberger Dec 3 at 23:48
  • I thought it included the lm* tools, but you can probably also click "Server Status → Perform Status Enquiry". Have you tried entering the server name with @ prefix? – grawity Dec 4 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.