1

My current machine is a Aftershock 65xHP [Intel Core i7-7700HQ] Running on Intel(R) HD Graphics 630 on a Clevo motherboard. I also have an NVIDIA Geforce GTX 1060 graphics card.

I tried a few versions of Intel(R) HD Graphics 630 drivers and all of them prevent my Laptop LCD screen from working. (I had to connect to an external monitor via HDMI to view my screen)

only 1 version of this graphics driver worked for me.

that is - 25.20.100.6519 - dated 1/9/2019 by Intel [See image - 1]

every now and then, windows update will update this driver and my LCD screen will stop working. All other solutions such as rolling back a driver will not work if I'm away from an external monitor; isn't the point of owning a laptop being able to work without an external monitor?

Can someone offer a solution to stop this update?

1
  • You don’t indicate what version of Windows 10 your using – Ramhound Dec 4 '19 at 3:47
1

It looks like windows 10 on your machine from the shared screenshot. You can disable all type of device driver updates by the following:

  • Right-click on "This PC" and select "Properties"
  • Click "Advanced system settings" in side-panel options (System Properties windows will appear)
  • Go to the "Hardware" tab and click the "Device Installation Settings" button
  • Select "No (your device might not work as expected)" radio button and "Save Changes"

This shall prevent any future automatic device driver updates included in Windows Update.

However, this will not uninstall any existing installed updates which may be causing you problems. You can do it manually from the following:

  • Open "Control Panel" > "Programs and Features" > "View installed updates"
  • Select particular update/driver causing trouble and right-click to "uninstall" it (a reboot may require)
1
  • Thank you I used the first solution you recommended. I think my laptop will be safe now! Thanks again. – John Dec 4 '19 at 8:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.