1

I tried to remotely wake up my Windows 10 laptop by connecting an Ethernet cable from my Raspberry Pi to an Amazon Basics Gigabit Ethernet USB Adapter, which I plugged into the USB 3.0 port of my laptop that I'm trying to remotely wake up. The lights on the Adapter turned on while my laptop was on, but whenever I hibernate or sleep my laptop, the lights turn off on the Ethernet adapter.

On the laptop I'm trying to remotely wake up, I have tried going into BIOS to enable USB charging in the off state and disabling USB selective suspend setting and "Allow the computer to turn off this device to save power" in power management for the Ethernet Adapter and USB Root Hub (USB 3.0), but this still happens. On the other hand, I was able to charge my phone when plugging it into the same USB port of my laptop that I'm trying to wake up while the laptop was on hibernate or sleep.

When I turned the laptop back on manually, I ran powercfg /DEVICEQUERY wake_armed in my command prompt, and my network adapter associated with the Ethernet USB adapter appeared on the list, so I'm still trying to figure out why I couldn't remotely wake my laptop.

If anyone can help, I'd greatly appreciate it. If I can get the lights on the Ethernet USB adapter to stay on while the laptop is off, I can use the Raspberry Pi to remotely wake up my laptop.

0

In order to power on or wake up your laptop by using the network, you need to enable Wake On LAN in the laptop's BIOS. You should be able to find it in your BIOS, however you can always check your laptop's manual.

Enabling USB charging will have no affect. This simply allows devices to draw power from the laptop's battery through the USB power lines. No data is being transmitted to the computer, therefore it cannot wake the computer up from sleep.

  • I switched the option to "Yes" for Touch Pad S3 Wake-up and USB S3 Wake-up and USB Charging in my laptop's BIOS and the same thing happened as before: the lights on the Ethernet USB adapter wouldn't be on if the laptop went into hibernate or sleep mode. In the BIOS section in my laptop, I don't see a Wake On LAN feature explicitly shown. – qccaprospect Dec 4 '19 at 9:12
  • I switched my laptop with a Windows 7 laptop that explicit showed the Wake On LAN feature in BIOS and enabled that feature. The same thing happened: I couldn't remotely wake that Windows 7 laptop on. I notice that sometimes, my power management option changes even though I set it to a certain way...maybe that might have something to do with this? – qccaprospect Dec 4 '19 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.