8

Fresh install of CentOS 5.4

Downloaded the following:

http://prdownloads.sourceforge.net/webadmin/webmin-1.510.tar.gz

MD5 sum is correct (cdcc09d71d85d81914a90413eaf21d3f). The file is located here:

/tmp/webmin-1.510.tar.gz

tmp and webmin-1.510.tar.gz both have chmod 777. I am logged in as root.

Command:

tar -zxfv webmin-1.510.tar

Result:

tar: v: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: webmin-1.510.tar: Not found in archive
tar: Error exit delayed from previous errors

Never run across this before. It's like it thinks that v is a file I want to extract, but its one of the command arguments...

If I leave out the v...

tar -zxf webmin-1.510.tar.gz

The command stalls. It doesn't do anything. Just goes to the next line and no prompt comes up. I have to CTRL-C to get back to the prompt and a ls verifies that it didn't extract anything...

My first reaction is that its not a valid tar/gz file or something. But the MD5 matches just fine. So I'm at a loss just a bit...

UPDATE

Wow. Never new that the order of the arguments mattered. Wonder why I've never noticed it after all these years.

However I just tried

tar -zxvf webmin-1.510.tar.gz

And the terminal is still stalled and I have to CTRL-C to get a prompt again. And to reiterate myself, if I ls there is NO webmin-1.510 directory after this procedure. Nothing is extracted.

UPDATE 2

I also just gunzipp'ed the file, so now I have a webmin-1.510.tar. I just tried the following:

tar -xvf webmin-1.510.tar

And again, same result. The command stalls the terminal and I have to CTRL-C to get a prompt. Nothing extracted.

  • Responding to Update 2: Do you have strace on your system? Running the same command under strace (strace tar -xvf webmin-1.510.tar) may provide clues. – coneslayer Jun 9 '10 at 19:26
  • 1
    Your tar could be perverse and interpret the - as "read archive from stdin". Some really old versions of tar didn't grok the - as an option signifier and weren't too picky about argument order. I'm guessing Ctrl-D (EOF) will stop your "stalled" tar. Modern GNU-tar accepts tar xvf foo.tar in homage to the old ways. – msw Jun 9 '10 at 22:42
15

The 'f' option needs to come at the end. It tells tar that what follows is the tarball name. Your command should be:

tar -zxvf webmin-1.510.tar.gz

The 'v' option is for verbose output. I bet if you did an 'ls' in the current directory, there's going to be a webmin-1.510 or such directory.

  • No, -f doesn't need to come at the end. But it needs to be directly followed by the argument it expects: the tar file name. Then, other options can follow behind: tar -f webmin-1.510.tar.gz -zxv would be OK. (But it seems there was also some other problem which led to the original question) ` – mivk Jan 13 '19 at 22:14
0

Do the following:

Go to root if necessary:
# sudo su
# cd ~
# wget http://prdownloads.sourceforge.net/webadmin/webmin-1.510.tar.gz
# tar -xvvzf webmin-1.510.tar.gz

It should now be extracted. It's possible system can't untar from and to your /tmp dir.

-1

I had a similar problem, but it turned out that I wasn't logged in as the user that owned the file. Once I logged it the file unzipped fine.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Ramhound Oct 2 '15 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.