0

I've got a PC running on Ubuntu 18.04 and a Huawei E8372 4g wingle. I'm trying to convert it into a web-server and I've installed opessh and also set up a ddns using no ip to solve the dynamic IP issue. However, I'm still not able to log into it via SSH over the internet. Only able to login over LAN using it's static hostname 192.168... How should I go about fixing this?

Thanks

  • You need to allow traffic to the OpenSSH server port on the router the PC is behind. I always recommend using DNAT to forward a high port (>40000) to the local port the OpenSSH server is running on, but whatever port you choose to forward, do not forward WAN 22 to LAN 22 – JW0914 Dec 8 '19 at 15:21
  • @JW0914 Thanks for the reply! I followed your instructions and the instructions from portforward.com and set the port forwarding this way: i.imgur.com/A8kSPI7.png However, it still is not working. Am I missing something? Thanks – honter safioun Dec 8 '19 at 16:39
  • Sorry added wrong screenshot. This is the proper one: i.imgur.com/wy4Ilk2.png – honter safioun Dec 8 '19 at 17:10
  • @hontersafioun Have you opened the SSH server port in the firewall on Ubuntu? Just to verify, you're attempting to connect to port 44444 when making the connection right? If both devices are connected to the same network for WAN (Wingle 4G), try to connect to the SSH server using a device that isn't connected to the Wingle, and if you're still getting a connection timeout, check the firewall log on Ubuntu and the system log on the Wingle (if it makes it accessible). – JW0914 Dec 9 '19 at 0:00
  • @JW0914 Sorry for not updating. Got occupied with some other stuff. Yes I'm trying to connect via port 44444 and have also opened it on the server. However, still no success :( Getting connection timed out error I also tried connecting after disabling all firewalls for a test. But still it didn't work out. – honter safioun Dec 14 '19 at 19:18
0

A typical method is to configure port forwarding in your router. How you do this depends on make and model of router. Some call it pinholes, some DMZ but it is port forwarding.

Your Wingle might not support this. Its user guide doesn't cover this.

|improve this answer|||||
  • I do see options like DMZ, virtual server, special applications, etc on the settings page. i.imgur.com/3RQzhFX.png However, I'm not sure what to do really. A total noob to this. Really sorry for that – honter safioun Dec 8 '19 at 14:29
  • @hontersafioun !! DO NOT configure the PC as a DMZ !!, you need to configure a DNAT [port redirect] rule under Firewall in the Settings. PortForward.com can walk you through this – JW0914 Dec 8 '19 at 15:25
  • @RedGrittyBrick Port forwarding and DMZ are NOT the same things, not even remotely. DNAT [port redirects] forward a single port or a port range to a device, IP, or MAC behind the router's stateful firewall, whereas a DMZ disables all firewalling of all traffic. Should a user configure their PC or server as a DMZ, it will be compromised and exploited within a matter of a few weeks, if not days/hours (analogous to directly connecting a PC to a modem, as while modems have a simple local DNS server, they do not have a firewall). – JW0914 Dec 8 '19 at 15:33
  • 1
    @JW0914: What you say is true but some router manufacturers have misused the terminology in the way I described. – RedGrittyBrick Dec 8 '19 at 15:44
  • @RedGrittyBrick Ah, that makes sense, as I read your answer in a different way. – JW0914 Dec 8 '19 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.