3

I'm trying to launch virtual machine from VirtualBox(6.0.14-133895 with extension pack) on Windows 64bit 10 Pro version 1903 18362.476 and frustratingly get the following error:

Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) 
(VERR_NEM_VM_CREATE_FAILED).

Result Code: 
E_FAIL (0x80004005)
Component: 
ConsoleWrap
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I tried everything from here, here, here, here and here: turn off features Containers, Hyper-V, Windows Sandbox, Virtual Machine Platform, Windows Defender Application Guard, Windows Hypervisor Platform, Linux subsystem, turn off Core Isolation Memory Integrity, disable VT-d in BIOS, reboot machine dozens of times, reinstall VirtualBox and reboot again. Tried this command also:

bcdedit /set hypervisorlaunchtype off

Nothing happens, I still get this error. I got Docker on my machine and everytime after reboot, system tells me that:

Hyper-V and Containers features are not enabled.
Do you want to enable them for Docker to be able to work properly?
Your computer will restart automatically.
Note: VirtualBox will no longer work.

Please help!

P.S. Here is my BIOS preferences: enter image description here

  • 1
    I'm voting to close this question as off-topic because it is about running macOS on non-Apple hosts, which is against the EULA and not supported. – slhck Dec 9 '19 at 7:43
  • Docker is the issue. Docker requires Hyper-V. – Ramhound Dec 9 '19 at 12:36
  • Does this answer your question? VirtualBox fails to start with VERR_NEM_VM_CREATE_FAILED – Ramhound Dec 9 '19 at 12:37
  • Docker doesn't work at the moment, because Hyper-V is disabled. Do you think, that Docker can keep Hyper-V implicitly turned-on? As for mentioned question - of course I have tried every solution from there=( – KozhevnikovDmitry Dec 9 '19 at 12:41
  • What happens when you turn VT-D on in your BIOS? – aman207 Dec 9 '19 at 18:53
1

This helped me with exactly the same error:

My hunch was that turning on Sandox activated some part of Hyper-V which was not deactivated when Sandbox was turned off so I installed Hyper-V (no Sandbox), rebooted and then immediately uninstalled Hyper-V and rebooted twice. No more error message. Both VM's working as I expect them to.

by fieldar from https://forums.virtualbox.org/viewtopic.php?f=38&t=92453&start=75

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.