1

I want to disable DWM on Windows 10 x64 1903,

this guide worked for me, but it is not working anymore on Windows 10 1903.
In the last step, when i am supposed to run "explorer.exe", my desktop won't restore.
Is there a way to disable it ? I own nvidia graphic card with drivers 436.30, if it is of any relevance.

I wouldn't ask if it wasn't important, but DWM cause extreme amount of input lag, it is definitive service to disable !!!

1

1 Answer 1

3

In W10 you can do this easily, even though it doesn't show in any settings. The ability is still there, but you have to do it via registry.

The easiest way is to first do a manual adjustment to the program you want to use, using the compatibility tab. For instance, change it to Run as Admin.

Once this has been done, find the setting in registry, looking at

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers].

Find your program, add DISABLEDWM to the data listed under the program, remove the RUNASADMIN and away you go.

This method is still working for me on 1909.

1
  • That never seemed to work for me on Windows 10. I just tried it again, DWM just stays enabled, and the application window doesn't change at all.
    – Ray
    Sep 16, 2021 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.