0

It's a 16GB Samsung. The phone (Samsung S3) told me that the card was corrupted and needed to be reformatted.

I thought it's just a file system error, so I plugged the card into a PC and the card loaded the drive letter E: and the root directory's subfolders were visible in the left bar in Explorer, but froze when I tried to click through to them.

Tried chkdsk E: /F which caused CMD to hang without starting chkdsk (there was no info loaded underneath the command). Restarted and tried again with same effect. Tried on another PC, same result.

Plugged the SD card into a Mac. Drive does not load in Finder, but when unplug the card, it says that the drive was incorrectly removed without being stopped.

This is about the limit of my recovery expertise... as there is nothing that is reading the card without hanging the system, I think there is no software in Windows or Mac (such as Easeus) to recover the data.

Any other suggestions?

  • The card is dead and should just be replaced. – Mokubai Dec 10 '19 at 21:56