4

I'm currently setting up my work system and totally lost at getting Microsoft Teams running. Other Microsoft Office products (like Excel, Office, Word) are working seamlessly for both native and web version, and for now only Teams seems to not work (also for both native and web).

Whenever I try to sign into Teams there's a redirection loop:

https://teams.microsoft.com/go# <-> https://teams.microsoft.com/go#id_token=xxx&session_state=xxx

... until being redirected back to the login page after about 10 seconds with the vacuous message: "We couldn't sign you in. Please try again."

It's working on a colleague's system, so it's not an account or licence issue.

I googled it, tried Chromium, Firefox, Opera, several packages like the widely-used teams-for-linux and even the official client for Insiders, ms-teams, tried both AUR and Snapcraft packages, and even built them myself - nothing worked. It's always the same behavior as described above.

I'm using the i3 community edition of Manjaro (freshly installed).

I'd be very thankful for any kind of ideas.

  • 4
    Try re-syncing the time with an internet time server. Question: Did you change the password just before this started? – harrymc Dec 16 '19 at 20:05
  • 1
    Oh my... yes indeed, I always use UTC on my devices and usually leave other things default. I set them equal and everything works now. Man! I would have NEVER guessed that without your input. Please write it as an answer so I can accept it. :) Thank you! – Marcello Mönkemeyer Dec 19 '19 at 9:33
4
+50

The difference between your computer and that of your colleague is most likely that of the clock.

I suggest to re-sync the time on your computer with an internet time server.

| improve this answer | |
1

I have same issue, you can execute these commands (Tested on ArchLinux):

We will activate the service, to activate synchronization between the computer and the servers on the internet:

sudo systemctl enable systemd-timesyncd.service

We start the service :

timedatectl set-ntp true
| improve this answer | |
  • 1
    @MMM Sorry, I updated the comment ^^ – Bensuperpc Mar 17 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.