11

I just updated Chrome to version 79, and I noticed that prefixes like https:// and www. have disappeared again. Before, I fixed this by setting the omnibox-ui-hide-steady-state-url-scheme-and-subdomains flag in chrome://flags to Disabled. However, that flag isn't there anymore, and I don't see what it was replaced with. What's the new way to fix this?

Update: I tried setting temporary-unexpire-flags-m76 to Enabled. While this brought back the above flag, it no longer works. As soon as I set it and relaunch, it gets set right back to Default.

1
15

These instructions are from https://jdtechservices.net/tools/.

The first method, which I prefer, is to add a parameter to your Chrome shortcut inside the target field:

--disable-features=OmniboxUIExperimentHideSteadyStateUrlScheme,OmniboxUIExperimentHideSteadyStateUrlTrivialSubdomains

If you are using Windows it will look like this:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-features=OmniboxUIExperimentHideSteadyStateUrlScheme,OmniboxUIExperimentHideSteadyStateUrlTrivialSubdomains

like this

Capture.png

The second method is to install an extension, but this will consume some memory:

https://chrome.google.com/webstore/detail/suspicious-site-reporter/jknemblkbdhdcpllfgbfekkdciegfboi

7
  • 1
    http:// still not shown... any idea how to show it? – dentarg Dec 15 '19 at 13:20
  • 1
    @dentarg Not a direct answer, but UnGoogled Chromium will (potentially) show e.g. http. You can get up-to-date unofficial builds here. – Anaksunaman Dec 16 '19 at 23:00
  • Downside to installing Google's Suspicious Site Reporter extension is that it gives Google permission to read the browsing history. - Ghacks – xypha Dec 17 '19 at 3:52
  • @dentarg make sure to paste it into the target field i.postimg.cc/63tC0vnm/Capture.png – theggputest55 Dec 19 '19 at 6:09
  • @theggputest55 I'm on macOS. I start Chrome like this open /Applications/Google\ Chrome\ Canary.app --args --disable-features=OmniboxUIExperimentHideSteadyStateUrlScheme,OmniboxUIExperimentHideSteadyStateUrlTrivialSubdomains (example with Canary, but I do the same with regular Chrome) – dentarg Dec 19 '19 at 10:05
4

Found an alternate solution on this Reddit discussion

  1. Create a new folder and name it Restore URL.

  2. Paste the following into a text editor and save as manifest.json in the new folder.

{ "name": "Restore URL", "version": "1.0", "description": "Restores http and www in the omnibox", "key": "MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAowA8wOUQ8ShyITJ15B9rcJrnoolyo+OLj07g8QWBlEBikgszYwlbc88OIRL+dJOASok3yG6RQ60fvIjBrtNEk1yQZJfNwF/CN0jFrkE3HN3xVMoX0XIQPB93kDZARcfR5nwU3RUgwwWGTqt69KSSU8QzRRQJSEgM8GENa3OBhw1UBn/I/RbhaFcTykJSomo9j55goJwNzUhXTJk458DQ5diY+gWMadDXlDBa8cciCVlaGOjBV5ezmxnD6p1GXhrvyEKZP8IlreDJC2Nw9hxrT3GIo1FzbmeDPANKJ9pkY1H3LOVsGJDtytBpD/FRErlvfkJVqp3N5ifF2EQ8lOAHrQIDAQAB", "manifest_version": 2 }

  1. Go to chrome://extensions/ and enable developer mode.

  2. Click "Load Unpacked" and select the folder with your manifest.json file.

This installs an unpacked extension (not from Chrome Store) that fakes it's ID to look like Google's Suspicious Site Reporter without the bloat or privacy issues included within the original.

You should now have http, https and www restored until Chrome removes this workaround.

Note: This will remove Google's official "Suspicious Site Reporter" if already installed. You wouldn't need this solution if the official extension was installed anyway.. unless you want to replace it!

Incognito:
If you want to enable it in incognito, click on the extension icon [R] > Manage extensions > enable the option "Allow in incognito”.

To always run Chrome/Chromium with this unpacked extension:

  1. Start command line with "path to chromium or chrome" --load-extension="path to Restore URL folder" and/or
  2. add --load-extension="path to Restore URL folder" at the end of the target field in your Desktop / Taskbar shortcut

Replace text in quotes with actual path
(Credit to Rob W for this)

Up until Chrome 82, using the above method would result in a dismissable popup - "disable developer mode extensions" - every time you restart Chrome.

In Chrome 83 and later, there are no more popups and no downsides to this method except taking a bit of time to setup.

1
  • 1
    It's a duplicate of an older existing answer which has an explanation. – wOxxOm Dec 19 '19 at 8:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.