1

I installed Ubuntu 19.10 on a USB stick so I could keep my programs and files with me wherever I go. This has worked fine since I've only been using it on my Desktop PC which has Windows 10 installed as the main OS and I don't have any issues running Ubuntu from the USB stick when I need it; however, when I try to run Ubuntu on the USB on my laptop (Macbook Pro mid 2012) which is already running Ubuntu 19.10 it only shows an EFI partition or disk when I press 'alt' to boot into the Boot Menu.

Is there anyway I can fix this?

I've done some research and my idea is that there might be a problem with the EFI partition and maybe I need to create an EFI partition on the USB???

This is a bit over me so any input will help! Thank you.

1
  • 2
    If a Legacy/BIOS/CSM install, you can just install grub to MBR for booting. If drive is MBR(msdos) partitioned and BIOS boot. If BIOS boot and gpt you also need a bios_grub partition. But if UEFI, you need an ESP - efi system partition on the external drive. And UEFI only boots from /EFI/Boot/bootx64.efi file/folder in ESP on external devices. You can create ESP, and copy /EFI/Boot & /EFI/ubuntu to flash drive. The version of grub/shim that gets copied to /EFI/Boot/ as bootx64.efi requires more files in /EFI/ubuntu. Also may depend on other system, is it BIOS or UEFI?
    – oldfred
    Dec 14, 2019 at 15:36

2 Answers 2

1

I had this issue aswell when I installed Ubuntu on my sdcard. It could'nt find't any images since the EFI partition was empty and I had disabled legacy mode.

This link should help you get there without having to enable legacy mode (if at all an option).

2
  • Thank you for your quick response, I'll take a look at it and come back with results! Thanks a bunch!
    – Owlet
    Dec 14, 2019 at 0:16
  • The link you shared was very helpful in teaching me how to install grub on efi; however I found that your basically do this when you are installing from a virtualbox if you set it up correctly ;). Thyank you
    – Owlet
    Apr 8, 2021 at 18:47
1

I just wanted to share my solution to this. I was able to boot up on different computers but not macbook-pro or Dell G7 laptops.

I first downloaded Ubuntu .iso to my windows pc. I proceeded to run a virtualbox live image of the Ubuntu .iso file with no virtual hardisk added. Afterwards, I connected my usb and proceeded to install ubuntu on the usb. Since no virtual hardisk was added there was nowhere else to look for the installation process. I belive EFI and grub were also installed on the usb because I've now been able to use it on 3 different computers, but again... not the macbook-pro or the G7 Dell laptops I've tried it on.

Edit: I was able to boot into Dell G7 laptop by disabling Legacy Mode and a couple other options that were dependent on it and it worked flawlessly. The settings in vbox made it so that it was installed in Legacy mode into the usb. I'm guessing that you can tweak the virtual motherboard settings to boot in UEFI mode and then install the ubuntu onto the usb in UEFI mode that way.

Cheers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .