0

I have two Win10_64 Pro PC's. One is behaving as expected and the other is not and I can't figure out how to resolve the issue on the problematic PC. Something else that might be noteworthy is that I just upgraded from cygwin version 1.7 to 3.0.7 and the problem was introduced after the upgrade (it worked fine before).

The problematic machine has an issue where the Administrator account is not a member of the Administrators group:

$ groups
None Users INTERACTIVE CONSOLE LOGON Authenticated Users This Organization Local account CurrentSession LOCAL NTLM Authentication Medium Mandatory Level

However the working PC has a different groups output:

$ groups
None Local account and member of Administrators group Administrators Users NETWORK Authenticated Users This Organization Local account CurrentSession NTLM Authentication High Mandatory Level

In both cases, I run the cygwin shell using a shortcut (not using "Run as Administrator"). Beyond not having the Administrators group, I see there are differences in High vs Medium Mandatory Level and I'd assume those are related to the problem as well.

I understand I can run the cygwin shell in an elevated prompt, but I'd like to login via SSH and have full Administrator privs, which is why I'd like to resolve this issue on the problematic machine. I just can't figure out how to do that.

I have verified the Administrator account on both PC's is a member of the Administrators group using Computer Management -> Users -> Administrator -> Member Of tab and verifying they match. I have also ran mkpasswd -l > /etc/passwd and mkgroup -l > /etc/group, rebooted and the problem still persists (in case something was missed during the cygwin upgrade). I see conflicting feedback on the Internet about this though; meaning, cygwin may not do much with these files, and/or ignore them.

I have the default /etc/nsswitch.conf as well on both PC's:

$ cat /etc/nsswitch.conf
# /etc/nsswitch.conf
#
#    This file is read once by the first process in a Cygwin process tree.
#    To pick up changes, restart all Cygwin processes.  For a description
#    see https://cygwin.com/cygwin-ug-net/ntsec.html#ntsec-mapping-nsswitch
#
# Defaults:
# passwd:   files db
# group:    files db
# db_enum:  cache builtin
# db_home:  /home/%U
# db_shell: /bin/bash
# db_gecos: <empty>

My PC's are not part of an AD and we use strictly local logins (no association with Microsoft Live ID's).

Any help is greatly appreciated. Thank you very much!

2
  • Look closely at the administrator account that isn't working. User name "Administrator" is disabled by default even though it is indeed a member of the Administrator's group. Try logging into that PC directly using "Administrator". Dec 16, 2019 at 19:44
  • @SeñorCMasMas: Thanks for the response. I am currently logged in locally to debug the situation. The Windows console login seems fine. Is there anything I should look for after logging in?
    – squad 51
    Dec 16, 2019 at 20:05

1 Answer 1

0

This is very interesting. The problem has fixed itself after acclimating for a few days. No actions were taken on my part, but there was an automatic Windows update that came through which rebooted the PC. I wish I had a more definitive answer. Perhaps it was the reboot, perhaps some soak time was needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.