When I try to execute sound in Rythmbox, it's "slow". Not only Rythmbox, but system sounds are strange too (they look like they are "slow").

I've tried a workaround but without success. It seens a ticket it's already opened for it, but I can't see a fix... Are other workarounds possible?

Anyone knows what this could be? I'm using Virtual Box 3.2.4 r62467.

Host Config:

Ubuntu 8.04

Kernel 2.6.24-19-386

Memory 3,0gb

Intel Core 2 Quad @2.66GHz

Free Space: 256,8GiB

VM (Guest) config:

General Name: Development OS Type: Ubuntu

System Base Memory: 1112 MB Processor(s): 1 Boot Order: Floppy, CD/DVD-ROM, Hard Disk, Network VT-x/AMD-V: Enabled Nested Paging: Enabled

Display Video Memory: 64 MB 3D Acceleration: Disabled 2D Video Acceleration: Disabled Remote Display Server:Disabled

Storage IDE Controller IDE Secondary Master (CD/DVD): Empty SATA Controller SATA Port 0: Development.vdi (Normal, 12,45 GB)

Audio Host Driver: PulseAudio Controller: ICH AC97

Network Adapter 1: Intel PRO/1000 MT Desktop (NAT)

Serial Ports Disabled

USB Device Filters: 0 (0 active)

Shared Folders Shared Folders: 1

  • 1
    Just to clarify, “slow” refers to sound distortion (low pitch and clock speed), not dropped samples. – Tobu Jun 10 '10 at 21:17
  • Ah, my clarification was off the mark. The workaround and the ticket weren't in fact relevant. Congratulations to the OP for solving the problem themselves. – Tobu Jun 11 '10 at 14:34

My co-worker solved it!!!

We were reading this tutorial, when we came across an interesting section:

If you have an HDA-Intel device try turning up the PCM slider in the volume control. If PCM is set to 0 it makes the sound scratchy for some of those devices.

Otherwise if your sound is scratchy or stuttering you can edit these lines in the file /etc/pulse/daemon.conf to look like this Code:

default-fragments = 5

default-fragment-size =25

There are also some sound cards/chips that can only be fixed with an ALSA upgrade so you may want to consider that if this does not work for you.

These are the words I couldn't think of (english isn't my native language): if your sound is scratchy or stuttering.

Then we thought: what about trying to mess up with this configuration? So we started changing these values in an arbitrary manner, when we realized the sound was changing, we came up with these values:

default-fragments = 8
default-fragment-size-msec = 25

(note that default-fragment-size is called default-fragment-size-msec instead).

...and now everything works. Tested in two different machines, two different vms, created from scratch and some that were already created that had this fix.

  • You should simply disable pulse in a VM or install OSS. But yeah this also works. :P – Shiki Jun 11 '10 at 16:16
  • I prefer this approach, since I have an old host and can't upgrade and I don't want to mess up with other drivers. – Somebody still uses you MS-DOS Jun 11 '10 at 16:47

The bug report and its workaround are plausible. Maybe the module parameters need to be adjusted for the exact sound driver your guest uses. You should try looking in dmesg if the ac97 clock speed varies across guest runs. If this is the same problem, but the solution needs to be adjusted, use lsmod and modinfo to find the correct parameter.


Here is another possible solution, posting to add more cross-references:

Appears to be a common problem for many Linux guests, regardless of host operating system.

A workaround/fix was identified by someone using Ubuntu 9.04 was to stick the following into /etc/modprobe.d/sound.conf (might need a .conf extension, or might not):

options snd-intel8x0 ac97_clock=48000
options snd slots=snd-intel8x0
# CvwD.FAMlirE10w6:82801AA AC'97 Audio Controller
alias snd-card-0 snd-intel8x0

More info @ https://askubuntu.com/questions/324889/multimedia-running-very-slow-weird-in-virtualbox

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.