0

I just got a new Thinkpad P53 with a Quadro RTX 3000 graphics card (roughly equivalent to the GeForce RTX 2060 consumer card), and am getting sporadic benchmark results for the graphics card. 3D Mark "Time Spy" score is sometimes 2900, sometimes 5500 (specifically, graphics test 2 gives consistent fps results from run to run, but graphics test 1 sometimes gives fps ~30, and sometimes ~10).

I'm getting similarly extreme osculation in Passmark 3d graphics benchmark (sometimes get a score ~5000, sometimes ~10000).

Laptop is plugged in and set to high performance throughout. No programs running in background, etc.

I've benchmarked a lot of computers (both desktops and laptops), and have never seen this kind of oscillation when the computer remains in a constant state (power supply, performance mode, etc.)

It's obviously normal to see small variations, but with this computer I run the test once I get one result, then run it again and the number halves... then run it several more times, and sometimes I get the first number, sometimes the second number.

I'm wondering if anyone else has seen this kind of benchmark variation, and whether it is indicative of a hardware issue, or whether it could be caused by Lenovo's power management software or something.

The weird thing is that Furmark seems to run at constant fps for hours, and 3D Mark 11 also seems to give consistent results from run to run...

Any help is much appreciated!


Update 1:

I have updated my BIOS and all my device drivers and nVidia drivers to latest available versions, run all Windows updates, Lenovo updates, etc.

Update 2:

I have made sure my laptop power settings are always on Maximum Performance, and that all relevant advanced settings are set to prefer performance over energy savings:

enter image description here

Update 3:

I have tried setting global nvidia control panel settings to always use the nVidia processor, and always "prefer maximum performance":

enter image description here

Update 4:

I have tried disabling my laptop's integrated graphics entirely via the relevant BIOS setting.

None of these adjustments have solved the problem.

Update 5:

I have purchased and run the full version of 3D Mark Fire Strike stress test, which has revealed the the problem does seem to be related to the GPU sometimes failing to reach the appropriate clock levels under load. During the stress test, clock rate would sometimes boost appropriately, and sometimes fail to boost until part way through the test (sometimes tens of minutes):

enter image description here

3
  • 1
    What about the thermals??
    – Valay_17
    Dec 19, 2019 at 4:37
  • 1
    Install GPU-Z and verify that your core clock is rising to expected levels. I had a Radeon 7870 which oddly got stuck at its idle 300 Mhz when launching a game; a restart fixed that issue and I never had that issue again. If you have integrated graphics then this would also help you verify whether the GPU automatic switching is being activated.
    – MonkeyZeus
    Dec 19, 2019 at 15:52
  • Thanks Valay_17 and MonkeyZeus for the pointers--they helped set me in the right direction to eventually find the source of the problem (see my posted answer). Dec 27, 2019 at 1:57

1 Answer 1

0

After much fiddling and troubleshooting, I have finally found an apparent solution to my GPU not always boosting clock rate appropriately during load:

In the nVidia control panel, I have selected each game/program that requires high performance, and individually set these programs to use the nVidia processor, and to prefer maximum performance:

enter image description here

Note that I had previously set the global settings to these same values (as per my original post updates), but that did NOT solve the problem. This may simply be an issue with current nVidia drivers, but apparently global settings are NOT truly global at the moment and/or global settings are unstable in some way.

4
  • So you think that the drivers are the root of the cause?
    – Valay_17
    Dec 27, 2019 at 2:43
  • Also even the latest devices need driver updates(because the manufacturer provides the most stable ones), you can find them here : support.lenovo.com/us/en and search for download updates option and also visit nvidia’s official website and for driver updates.
    – Valay_17
    Dec 27, 2019 at 2:52
  • @Valay_17 Thanks for the tips. I have updated my original post to indicate that I running all Windows updates, Lenovo updates, etc. did not solve the problem. I do think it's an nVidia driver issue. I have since read reports of other people experiencing similar issues (global settings not working as expected--having to set desired values on a per-app basis). Dec 27, 2019 at 3:00
  • Guess you gotta wait patiently for nvidia to solve this problem after all .... :)
    – Valay_17
    Dec 27, 2019 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.