2

Recently, I started getting a 500 error whenever I try to access my home automation system over the internet (SSL, DuckDNS, Apache2). If I locally access my home automation system over SSL, it works fine (https://localIP:port). I also have another webpage that uses the same setup (SSL, DuckDNS, Apache2), and even uses the same VirtualHost in Apache. Oddly, that webpage works perfectly fine.

I tried checking apache's error log for port 443, but it just leaves me clueless. I tried to do some searching, but all I find is "check your scripts, they have to be executable". I personally didn't change anything that could cause this issue to appear, but I suspect that Apache has been updated by unattendedupgrades, possibly causing the issue.

I've attached a section from the error log below, which is created after trying to access a JSON URL command from the home automation system. As far as I can see, the first entry immediately is a 500 error, and all the other errors are just not found errors, because it's trying to load resources from the other page (which is working, but requires a different URL).

How can I debug this issue?

Section from port_443_error.log:

myIP - - [19/Dec/2019:18:59:50 +0100] "GET /plugins/clockpicker/assets/css/bootstrap.min.css HTTP/1.1" 403 3033 "https://myWebsite.duckdns.org/domoticz/json.htm?type=command&param=getlightswitches" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:50 +0100] "GET /misc/stylesheet.css HTTP/1.1" 200 4738 "https://myWebsite.duckdns.org/domoticz/json.htm?type=command&param=getlightswitches" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 2457 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 2457 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 2457 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/manifest.json HTTP/1.1" 403 2457 "https://myWebsite.duckdns.org/domoticz/json.htm?type=command&param=getlightswitches" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 3033 "https://myWebsite.duckdns.org/domoticz/json.htm?type=command&param=getlightswitches" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 2457 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon-32x32.png?v=KmnbvPPwjy HTTP/1.1" 403 2457 "https://myWebsite.duckdns.org/domoticz/json.htm?type=command&param=getlightswitches" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon-16x16.png?v=KmnbvPPwjy HTTP/1.1" 403 2457 "https://myWebsite.duckdns.org/domoticz/json.htm?type=command&param=getlightswitches" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 2457 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:18:59:51 +0100] "GET /icons_stuff/favicon.ico?v=KmnbvPPwjy HTTP/1.1" 403 2457 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.134 Safari/537.36 Vivaldi/2.5.1525.40"
myIP - - [19/Dec/2019:19:00:11 +0100] "-" 408 575 "-" "-"

0

You must log in to answer this question.

Browse other questions tagged .