1

The keyword to my question i "paste", not "save".

My company uses a tool that will evaluate the Word documents we made, and one of the criteria is all the images must be in JPG. Regardless of what 3rd party screenshot I used (Lightshot, Greenshot, ShareX, Skitch), the pictures will always be pasted as PNG in Word. The tools have setting to save the image as JPG, but only for save, not copy to clipboard as JPG. This means whenever I paste an image from screenshot, it will be pasted as PNG, then I have to cut and paste special as JPG. Problem is most of my screenshots involves small details, and when cutting and pasting from an already pasted image, the resolution becomes significantly worse. I tried the "do not compress" and "high fidelity" options in Word, but no improvement in image quality.

So the only option I can think of is making sure when an image is copied into clipboard, it is already in JPG, so I don't have to repaste the image. Can anyone help guide me on how to do this?

Edit: So I found out that regardless of what image type you copy on, Word will always paste it as PNG. To convert it to JPG, you have to cut from the already pasted image in Word, and paste it again as JPG, which resulted is significant loss in quality. It seems it depends on the source of the image you copied from, where if Word doesn't recognize it, you can only paste in the default image format. If I can somehow change the default paste format in the registry that would be great.

Word not recognizing the source

  • How do you know it is the screenshot process and not Word that is saving the file as PNG? – music2myear Dec 20 '19 at 4:00
  • If you do have that requirement don't paste it but rather include it. If you are having problems with small details it's unlikely that's due to it being PNG as PNG, in comparison to JPEG, is a lossless format. Which is probably also why Word favors PNG over JPEG. – Seth Dec 20 '19 at 6:36
  • @music2myear honestly I don't know which is the issue, the process or Word itself. If it's due to Word and there's a solution for it, I will be happy too. I just want to make sure when I pasted it, it will be in JPG. – maryaras Dec 20 '19 at 8:08
  • @Seth can you clarify what do you mean by include it? Meaning save as attachment? Unfortunately I have to paste it for the report customer's convenient. – maryaras Dec 20 '19 at 8:10
  • 1
    Instead of pasting an image just include it through the option to insert an image. You might also want to bring it up that PNG isn't a bad thing and could even improve the quality of the documents you create. – Seth Dec 20 '19 at 9:49
0

I managed to find a solution for my problem, and want to share with you guys. But it is only applicable with MS Word, since it is what I am having issues with. So basically you need to use ShareX, and set it so that the image format output is JPG. Then, MOST IMPORTANTLY, use the “save, copy image file” option from the quick task menu that popped out whenever you take a screenshot. If the menu does not pop up, set it so. Now when you paste it into MS Word, it will automatically be pasted as JPG.

Why this works is because I think MS Word only recognize the image type copied from certain source. If it doesn’t recognize the source, it will be pasted as PNG/bitmap by default. So when you setup ShareX per above steps, you are saving the pictures in your PC. Then ShareX will automatically copy from the image file itself (which Word recognize), so you can directly paste it as JPG into Word.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.