0

In my Windows 10 computer I have VS Code and Cygwin installed. I use Cygwin bash as the shell for VS Code. I also have the Anaconda Python distribution installed.

Whenever I open a new shell in VS Code, it tries to run

cd C:/path/to/a/folder/that/does/not/exist/
conda activate base

This obviously fail. But I do not care, because my shells work great as they are. I do not want to activate conda.

How I do I make my bash inside VS Code stop running those 2 commands?

EXTRA INFO: This does no happen on normal Cygwin shells (outside VS Code) This only happens for a new shell. The shell that opens as VS Code starts does not do this.

  • Check if Vscode has any anaconda extension or something. Also check if .bashrc or .bash_profile in cygwin home folder has any conda related commands. – Biswapriyo Dec 20 '19 at 13:43
0

Found the solution on https://github.com/Microsoft/vscode-python/issues/4305

One needs to add

"python.terminal.activateEnvironment": false,

to settings.json

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.