0

I have trouble upgrading my computer (Surface Pro 1 128GO, bought in 2014 on Windows 8.1 pro in Europe) from Windows 10 Pro 1809 to 1909. Windows Update always return the same error code (0x80070003). I tried to
-free a lot of space
-uninstall Avira
-perform a chkdsk
-try to find what this error code means here but without results
-disable the Windows Subsystem for Linux (I don't have any dual boot on this computer)
-check for Bios update (there is not)
-use the Windows Update Troubleshooter provided here which said there is nothing to fix
-use the windows upgrade tool provided here, which return the same error code
-burn a windows usb flash drive installation from the Media Creation Tools, provided as the same place that above, which still return the same error code.

I have no more ideas, found nothing on the Internet (except that this error code already existed in Windows xp), and Windows 10 1809 will not be maintained any more after the 20 may 2020, and I'm not very "happy" about the idea of making a whole new installation and loose all my software, browsing history and parameters.
But except that, everything works fine on my computer.
Do you have any ideas ?

Best regards

EDIT : my last cumulative updates (translated)

2019-12-13 cumulative update for .NET Framework 3.5, 4.7.2 and 4.8 for Windows 10 1809 x64 (KB4533094)
2019-12-13 cumulative update for Windows 10 1809 x64 (KB4530715)
2019-12-09 cumulative update for Windows 10 1809 x64 (KB4523205)

EDIT : Here are the results from SetupDiag

Matching Profile found: WimMountDriverIssue - 565B60DD-5403-4797-AE3E-BC5CB972FBAE
SetupDiag version: 1.6.0.0
System Information:

Error: SetupDiag reports failure determining wimmount.sys file version.
Last Phase: Pre-Finalize
Last Operation: Mount WIM file C:\$WINDOWS.~BT\Sources\SafeOS\winre.wim, index 1 to C:\$WINDOWS.~BT\Sources\SafeOS\SafeOS.Mount
DriverPath: C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\wimmount.sys
Error = 0x80070003
Refer to "https://docs.microsoft.com/en-us/windows/desktop/Debug/system-error-codes" for error information.
If DriverPath is not system32\drivers\wimount.sys, that is likely the issue. HKLM\SYSTEM\CurrentControlSet\Services\WimMount\ImagePath should be pointed to system32\drivers\wimmount.sys.

  • According to SetupDiag I went in the Windows Registry and made HKLM\SYSTEM\CurrentControlSet\Services\WimMount\ImagePath pointed to the good location, system32\drivers\wimmount.sys which should had work according to this <tenforums.com/windows-10-news/…> But the upgrade still doesn't work, I now have a new error in SetupDiag : "Error: 0x8007007B - 0x50015" so I gonna test the Windows Update Cleaner. – Rouletabille Dec 21 '19 at 13:29
  • The value was Assessment and Deployment Kit\Deployment Tools\amd64\DISM\wimmount.sys – Rouletabille Dec 21 '19 at 13:30
  • What versions of the WIndows ADK do you have installed? – Ramhound Dec 21 '19 at 13:31
  • I put back the path as it was. But I did not even know what ADK is. I did some research and remember that I once made a WindowsPE iso. It must come from that. In the control panel, the version installed is "10.1.18362.1" installed on 2019-04-18 – Rouletabille Dec 21 '19 at 13:58
  • Uninstall any version(s) of the Windows ADK you might have installed. – Ramhound Dec 21 '19 at 14:36
1

Windows Update always return the same error code (0x80070003).

This is due to the fact Windows is unable mount the required Windows image (*.wim) because your Windows ADK installation changed the value of ImagePath. The SetupDiag tool by Microsoft suggested this was the case.

HKLM\SYSTEM\CurrentControlSet\Services\WimMount\ImagePath should be pointed to system32\drivers\wimmount.sys.

Use the Disk Cleanup to delete any previous upgrade attempts. A Windows Update Cleanup might also be required. Windows Update history will be wiped by the process but this would happen anyways with a successful upgrade to Windows 10 version 1909.

You should uninstall any version of Windows ADK you might have installed. This will make the required changes back to their defaults.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.