I have a:

When I connect the Asus laptop to the Samsung Smart TV after 10 minutes it disconnects and it's hard to reconnect.

This is what I've done:

  • Updated to latest driver for graphics card using Asus LiveUpdate
  • Updated to latest driver for WiFi card using Intel Update download
  • Updated to latest firmware for TV using inbuilt software updater
  • Updated to latest BIOS firmware for laptop using Asus LiveUpdate

  • Factory reset Windows 10 Pro

  • Verified that the driver and hardware supports a wireless display using dxdiag
  • Verified that the system supports a wireless display using an alternate method (netsh wlan show drivers command in a command prompt)

  • Tried a LG V30+ Android mobile or Google Nexus 7 tablet device on the Samsung TV. This works fine.

  • Tried connecting the Asus laptop to a different LG webOS UM7600PTA smart 4k TV. This works fine.

I've spent a few hours on Microsoft Directly support; Samsung TV Support and Asus support.

I've asked for support on the web here:

Any suggestions?

The relevant hardware:

  • Intel® Core™ i7-8550U CPU @ 1.80GHz
  • Intel® UHD Graphics 620 with latest drivers dated 2018/02/28
  • Intel® Dual Band Wireless-AC 8265 with latest drivers dated 2019/09/10
  • Samsung UA55MU6103WXXY 4K Smart TV with latest firmware 1280.5 connected to Wifi Router on 5GHZ band.

Update 2020/01/03

  • Updated Intel® UHD Graphics 620 to latest drivers dated 2019/12/31
  • I forgot to mention. Samsung HQ had me connect both the TV and laptop to my mobile hotspot. They didn't specify the frequency band but it was also 5GHZ.
  • Samsung TV repairmen (Video Factory Electronics) came out but only tested their Android mobile to my Samsung TV which of course works as I"ve already told Samsung HQ. There was not good communication from Samsung HQ and Video Factory.

Still has issue.

  • 1
    Please don't just come and post your question into chat. However, have a upvote for actually doing some research. Dec 23, 2019 at 9:31
  • Regarding: "Tried a LG V30+ Android mobile or Google Nexus 7 tablet device on the Samsung TV. This works fine." and "Tried connecting the Asus laptop to a different LG smart 4k TV. This works fine." This is all using the Miracast feature, I presume, and thus, eliminates any one element as an obvious culprit. Is there any way you can connect your TV to your network via ethernet (wired), to see if that makes a difference (and of course the Laptop).
    – Steerpike
    Dec 26, 2019 at 5:48
  • Thanks for the reply. Miracast uses WiFi Direct so it shouldn't make a difference - en.wikipedia.org/wiki/Miracast Dec 26, 2019 at 6:57
  • @Darryn - since we don't know why it isn't working, and given the number of things you've already tried, 'shouldn't make a difference' seems a bit naive! Looks like Miracast can work over LAN as well as WiFi - docs.microsoft.com/en-us/openspecs/windows_protocols/ms-mice/… so can you at least try it to see if it DOES make a difference? I can't think of anything else to try.
    – Steerpike
    Dec 31, 2019 at 3:52
  • 1
    @Darryn - honestly, I have no idea. It sounds like you've tried everything reasonable, and for me when I get to that point, I start trying 'secondary' ideas. Sometimes, solutions appear when you try less obvious things. Maybe, when you run over ethernet, an error message will appear that reveals the root cause of the problem ... you just don't know till you try it. But - if it's a pain to try, maybe not worth it.
    – Steerpike
    Jan 2, 2020 at 7:54

2 Answers 2


I see your specs at Intel
TX/RX Streams  2x2  Bands 2.4 GHz, 5 GHz
(May want to try and only use 2.4GHz).
A lot of places out there don't support 5G yet.

Intel has put out a new driver also Windows 10 Wifi package drivers: 12/31/2019 21.60.2
Hope this helps you out.

  • How do I force Miracast to only use 2.4Ghz? Jan 3, 2020 at 4:11
  • Try setting your laptop band to use 2.4 GHz.
    – vssher
    Jan 3, 2020 at 4:13
  • Thanks for the reply and answer. Remember it's Miracast so uses WiFi Direct. So would it be a different adapter? Anyway trying the latest drivers. Jan 3, 2020 at 4:16
  • No, not a different adapter, you might just try and setup your wifi to use 2.4GHz. How to Connect to 5GHz Wifi on Windows 7/8 and 10 appuals.com/how-to-connect-to-5ghz-wifi-on-windows-7-8-and-10 Your very welcome Peace ;)
    – vssher
    Jan 3, 2020 at 4:20
  • 1
    You are really doing alot of researching and testing. I am glad your making progress. I am going to vote your question up and giving you a big A+ for all your status updates. Hope I helped, if even a little. Peace.
    – vssher
    Jan 3, 2020 at 5:16

Temporary Workaround

  • Connect the laptop to WiFi router via 5GHZ; then connected Miracast; then switched laptop to Wifi router via 2.4GHZ. This works fine for longer then 30 minutes so far.

However this is not a long term fix as 2.4GHZ is slower then 5GHZ. I am still not sure what the root cause issue is.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .