1

I try to rescue some data from my drive (with an NTFS partition), which out of sudden stopped working. Under Windows it doesn't mount properly into the system, causing a lot of hang-ups. I managed to mount it under tinycore Linux and was able to successfully list some of its directories. Listing some other directories caused I/O errors. So I decided to try ddrescue to rescue some data or at least the partition table, to see the filenames. Currently, I call it using the command ddrescue -a 100M /dev/sde seagate_disk.img seagate_disk.ddrlog. In the beginning, it looked kind of promising, with several days estimated execution time. But now it works very slow and I don't know if there is any parameter I can set to improve the runtime. I would accept a loss of accuracy.

Here is ddrescue's output:

GNU ddrescue 1.22
Press Ctrl-C to interrupt
Initial status (read from mapfile)
rescued: 482752 MB, tried: 46293 MB, bad-sector: 0 B, bad areas: 0

     ipos:  532900 MB, non-trimmed:   47241 MB,  current rate:       0 B/s
     opos:  532900 MB, non-scraped:        0 B,  average rate:   34421 B/s
non-tried:    1467 GB,  bad-sector:        0 B,    error rate:   21845 B/s
  rescued:  485663 MB,   bad areas:        0,        run time: 23h 29m 34s
pct rescued:   24.27%, read errors:    14463,  remaining time:         n/a
 slow reads:        0,        time since last successful read:     20m 25s
Copying non-tried blocks... Pass 5 (forwards)

And here's how the mapfile looks like in ddrescueview:

ddrescueview (higher resolution: https://i.snipboard.io/gZXqAU.jpg)

1

try ntfsclone with the --rescue parameter instead, it will ignore the empty parts of the volume. so any deleted files containing errors will be skipped.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.