4

My laptop came with Windows 10 pre-installed using UEFI and Secure Boot on an SSD, the Windows drive encrypted with Bitlocker. I pulled that SSD and installed Ubuntu on a new SSD.

I bought an external SSD enclosure with a USB-C interface and installed the original Windows SSD into it. If I attach this drive to my USB-C port, turn on the power and go to the BIOS boot options menu, the laptop gives me the option of running the Windows boot manager on the (now external) SSD. When I select the Windows boot manager, Windows tries to boot but fails after a few seconds with a BSOD and en error "Inaccessible boot device". This is a pretty generic error and from my research may have many causes, but I think the issue is that the drive location has changed and something in the boot configuration needs to change in order for me to boot Windows 10 from this device in the external enclosure.

I've looked at the BCD Boot options, but I don't have much experience with Secure Boot, UEFI, etc., and I was hoping someone could point me in the right direction to get the configuration updated so I can boot Windows when I need it.

9
  • It's the driver loading that is tricky.
    – Tom Yan
    Commented Dec 25, 2019 at 13:19
  • It is not recommended to run any OS, let alone Windows, from a USB connection, as you risk data loss when the USB plug is eventually bumped, either on the laptop or the enclosure (it's not a matter of if, but when). The recommended way to do this is to dual boot off internal drives... is there a reason you're not wanting to do so? (AFAIK, Windows does not, and has never, support[ed] running the full OS off a USB drive)
    – JW0914
    Commented Dec 25, 2019 at 14:03
  • 1
    @JW0914 Yes, I realize that's a better option, but I don't have a second internal SSD slot. I might just buy a new Windows 10 Pro license and install it alongside Ubuntu on the new SSD, but I'm trying to get this running in the meantime since I already have a perfectly good Windows install on the existing drive. FWIW, USB-C at 10 Gbps is plenty fast. I've successfully run VMs off of older USB SSD drives. Commented Dec 25, 2019 at 15:26
  • Why does one internal disk prevent dual-booting (unless it's only a 128GB SSD; and Windows licenses are tied to the motherboard, not the disk drive)? The USB-C protocol is capable of a maximum 10Gbit/s, but that is not the throughput you will get for several reasons: (1) throughput is dependent on the controller on the motherboard; (2) Laptops, generally, do not have a dedicated controller for every USB port [each port shares the same controller], which means the available throughput is halved for every USB device connected. Windows has never supported full OS booting from a USB drive.
    – JW0914
    Commented Dec 25, 2019 at 15:36
  • @JW0914, See my earlier comment. Cloning the partitions on the old drive to the new one is possible, but I've had enough issues cloning drives that I thought this might be the easier route. Apparently not, though. Commented Dec 25, 2019 at 15:53

2 Answers 2

2

you just need to set HKLM/SYSTEM/HardwareConfig/{..guid..}/BootDriverFlags = 0x14 - these BootFlags correspond to CM_SERVICE_USB_DISK_BOOT_LOAD + CM_SERVICE_USB3_DISK_BOOT_LOAD.

2
  • I am in the same situation as the OP and this did not change anything. BTW I managed to access reg.exe via a command prompt in the Advanced recovery of windows. The value of BootDriverFlags vas 0x1c, setting it to 0x14 did not change the situation.
    – ggll
    Commented Nov 26, 2022 at 12:26
  • This worked perfectly for me. Commented Apr 17 at 10:38
0

Just tried the answer above with setting HKLM/SYSTEM/HardwareConfig/{..guid..}/BootDriverFlags to 0x14 and it worked perfectly.

Note that 0x14 is a Hexadecimal value and is equal to 20 in Decimal

My install had 2 GUID values and so changed in both. Worked like a charm & Windows booted up as if nothing changed.

Troubleshooting a disappearing disk issue and need to isolate the inbuilt SATA controller. As I donot have the rep to upvote the above answer or add a comment to it, just adding this +1

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .