enter image description here

enter image description here

This recently started this month and I found out that my Logitech Setpoint application was doing it. So I turned it off within the app. It randomly popped back up again in the last 2 days. And the app already has the feature off. I have uninstalled, reinstalled, restart, and this dang caps lock will not go away.

I don't have a Lenovo. I've also looked at this forum "How to disable Caps Lock/ Num Lock notification Windows 10?."

Troubleshooting Tried:

  1. Disabled HKCMD startup

  2. Display adapter will not give me screen configurations

enter image description here

  • 1
    It gives you state information (especially when entering case sensitive passwords) . It goes away in 2 or 3 seconds. May I suggest you just adapt to it.
    – John
    Dec 25, 2019 at 13:40
  • @John there is way to turn it off, but I'm unsure of the process. It will either be in Windows Settings, Control Panel, or in one of the ASUS system utility programs
    – JW0914
    Dec 25, 2019 at 14:51
  • Yes. However, it is the kind of notification needed (in the absence of a LED indicator). @Yagami - look for a Function Key app/driver in Device Manager and update that. This is where the function lives on my computer.
    – John
    Dec 25, 2019 at 15:12
  • My Asus does not have this. This post says it might be from Logitech.
    – Michael S.
    Dec 25, 2019 at 17:52
  • We have all kinds of LogiTech devices at clients (and I myself here) and the LogiTech devices do not create this icon. I know the same icon on my own machine and it is manufacturer's software. So ASUS may have built it into BIOS if they do not have any other software causing this.
    – John
    Dec 25, 2019 at 19:26

2 Answers 2


I recently paired a Logitech K380 and am using their Logitech Options software. I found settings within the keyboard for Notifications. Please check for NOTIFICATIONS > A LOCK KEY IS PRESSED. I hope this helps, I see this is an older issue and just want to help.


I had this same issue, and like @Harold mentioned it turned out to be the Logitech Options software causing these popups.

For reference, here is another example notification caused by the Logitech Options software: Screenshot of the "Caps Lock On" notification generated by Logitech Options

Here are the steps to disable the setting:

1. Open Logitech Options

If you have multiple devices (like shown in my screenshot), select a keyboard device. You can do this even if the device is not currently connected to your computer (as is the case when I took these screenshots). Screenshot of Logitech Options software showing multiple devices, including a keyboard

2. Open the More Settings menu

Access this menu by clicking the "MORE" button. Screenshot of Logitech Options software showing the More button

3. Turn off the notification

Under the "Notifications" section, there's a notification for "A lock key is pressed". Disable this notification. Screenshot of Logitech Options software showing the Notifications settings

Now the on-screen caps lock indicators should no longer be present!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.