2

I have added a SSD to improve the performance of my laptop. I replaced the existing HDD with SSD in the main slot and then replaced my optical drive with the HDD. Then I did a clean install of Windows onto the SSD. As I already had Windows on the HDD, on startup, it showed me option to choose which Windows to boot, at Volume 2 or Volume 5. Volume 2 booted on SSD and 5 on HDD. To get rid of the Volume 5 Windows, I formatted the drive in HDD which had the Windows installed, but I am still getting the prompt every time I restart my PC. How do I get rid of the volume 5 Windows? I didn't try booting the Volume 5 after formatting as I was worried it may cause some problems as no Windows is there on the HDD. How to get rid of the other Windows?

1
  • If you used the same Windows 10 license (likely), it may be confused. Turn off, remove the HDD entirely, start up. Does it start?
    – John
    Commented Dec 26, 2019 at 2:04

4 Answers 4

3

The old Windows boot entry still hanging out there shouldn't be a concern that it might corrupt your system: you formatted the HDD making it unbootable anyway.

However if every time you start your computer you get asked which partition you want to boot to, that's quite annoying.


We can delete the old Windows boot entry using BCDEdit so that the BIOS no longer gets confused and let us choose.

This is very dangerous! You might want to backup your EFI partition first!

Step 1-3: Run elevated cmd.exe

  1. In Windows, Press Ctrl+Shift+Esc
  2. In task manager, File > Run new task
  3. Type cmd, tick Create this task with administrative previliges then hit Enter

Step 4-8: Find the broken boot entry and delete it

  1. In command prompt, type bcdedit /enum firmware /v and hit Enter
  2. You should find 2 Windows Boot Manager entries
  3. In your case one of the entries should say
device                  partition=\Device\HarddiskVolume5
  1. Copy the identifier of this unwanted entry (The long string of letters and numbers surrounded by curly braces) by selecting it with your mouse and right click
  2. Scroll down to the bottom and type bcdedit /delete, leave a space and right click to paste in the idetifier. The full command should look similar to this:
bcdedit /delete {9dea862c-5cdd-4e70-acc1-f32b344d4795}

Double check the ID. Then hit Enter

Reboot and BIOS won't ask you to "Select Boot Device" anymore

1

Press Win + R, type msconfig, select Boot, click on entry you want to delete and press Delete

0

With regard to the comments above, I strongly suggest removing the HDD entirely before doing the install on the SSD. This will prevent Windows licensing and activation being confused. I have done this successfully and the results were perfect. Keep the drives separate and only have one drive installed when installing Windows 10

-1

Try to make the first boot directly to the ssd and disabled the options of the boot menu.. That's not actually good solution, you might reinstall window os into ssd while hdd installed.. And do format it again from menu of windows installation..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .