0

I have an old (around 5 years old) 1 terabyte HDD that I've used to store all my DVD movies for easy access.

For some reason my Lenovo W520 has stopped recognizing this USB 2 HDD. I plug it in and I get a message telling me that the last device is not recognized. This is the same message I get when I plug in my Samsung Galaxy S10e – actually, any phone I've tried to connect recently. The phones connect for the first few weeks; then they fail. I've searched for, read and tried all the possible solutions on the net. Samsung replaced my latest phone and I have connection again; for how long I don't know. I just connected my phone to my W520 laptop and it's still connecting properly.

This HDD problem is almost identical to connecting the cell phone problem. The biggest difference is that File Explorer opens after a long wait (5 to 10 minutes) but it does not populate. After maybe another 1 or 2 minutes a window pops up and tells me that the HDD needs to be reformatted. When I cancel the reformat window, the Explorer populates, labeling the external drive as a local drive. I can't interact with the File Explorer though; the icon shows as a rotating blue circle.

The disk manager also will not populate. In fact it appears like it never will as long as the USB 2 HDD is attached. I disconnect and it populates immediately.

Back to HDD. It's been plugged in about 15 minutes and I can now interact with the HDD, though the command responses are slow. The HDD is now labeled correctly as well. I deleted a file and the delete progress window opened. It hung for quite a while before it finally deleted the file. I tried to cut a file and paste it onto another HDD. It starts the transfer and reaches 10% and the transfer drops to zero. It's been 10 minutes and I just got a message that the file cannot be read from the drive (My USB 2 HDD).

Any suggestions?
I'm at my wits' end. I don't know where to turn next.

1 Answer 1

1

You can try to remove the device using Device Manager, and the have it scan for hardware changes, as National Instruments recommends for their equipment, or remove USB drive information from the Registry, and reattach the drive.

It's also likely the drive is failing. After a read failure, Windows attempts to read the sector for a specific number of repetitions... this can slow reading, or eventually terminate it. There are a number of disk utilities such as ZAR Zero Assumption Recovery and alternatives that can skip bad sectors (of course, losing some data) and/or increase the number attempts to read (s l o w i n g it down), perhaps recovering your files. If you can, salvage as much data as possible, then try formatting the drive and testing it, possibly discarding it.

How would a drive fail though not in use? A few possibilities:

  • Enclosures are imperfectly sealed, and dust or atmospheric pollutants can enter.
  • Outgassed organic material can precipitate on the disk. Many drives have activated charcoal packets to adsorb that material, but they don't get it all.
  • Mechanical shock can scratch platters or destroy read-write heads.
  • Head alignment can change over time.
  • Magnetic domains may weaken.

BTW, an HDD has powerful rare-earth magnets, worth salvaging for experiments.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .