21

I'm using Gimp for Mac on a 4k screen and the interface text and icons look tiny. How can I make it bigger?

4 Answers 4

22

Change icon size

  • Preferences
    • Interface
      • Icon Theme
        • Change: guess Icon size from resolution
        • Into: custom Icon Size
        • Drag slider

Change font size

  • Close Gimp
  • Open the file gtkrc of your specific theme in a text editor
    • Open the Gimp themes directory:
      • Mac: /Applications/GIMP-2.10.app/Contents/Resources/share/gimp/2.0/themes/
      • Windows: C:\Program Files\GIMP 2\share\gimp\2.0\themes\
      • Ubuntu: /usr/share/gimp/2.0/themes/
    • Open the gtkrc file for your theme:
      • Light: Light/gtkrc
      • Dark: Dark/gtkrc
      • Gray: Gray/gtkrc
      • System System/gtkrc
      • other
        If you have a customized Gimp, look here for the gtkrc file
        • Mac: ~/Library/Application Support/GIMP/2.10/themes
  • Find line with: GimpDock::font-scale = 0.8333
  • Replace with: GimpDock::font-scale = 1.6666 (or another value)
  • Start Gimp again
9
  • 2
    Custom Icon size behaves strangely: large and huge are smaller than medium size on my DELL xps 15 4k (gimp 2.10.18) gitlab.gnome.org/GNOME/gimp/issues/2313
    – lrkwz
    May 3, 2020 at 14:36
  • 1
    Linux equivalents in Ubuntu are in /usr/share/gimp/2.0/themes/Dark/gtkrc and similar for the other themes Jun 11, 2021 at 14:14
  • 1
    Thank you @LucasW, added! Jun 14, 2021 at 14:06
  • This works for almost every UI element, but the main menu bar is still small for me. I suppose that's being controlled by the desktop environment.
    – Pistos
    Oct 31, 2022 at 15:09
  • @Pistos see answer explaining to change the font.
    – David Rios
    Dec 16, 2022 at 16:27
10

Under Bodhi Linux a better solution for me is similar to Bouke Versteegh's except leave.

GimpDock::font-scale = 0.8333

alone. Instead, uncomment

# font_name = "sans 10"

and change it to

font_name = "sans 20".

If you examine the gtkrc file, you will see there are several places where various font scales are specified. Changing the font changes them all without fussing with specific scales. If you want to tweak it afterwards, then you can alter specific scaling settings to change relative sizes for various parts of the interface.

Note: I had previously altered the bootup system environment variables with

GDK_SCALE=2

which GIMP apparently does not honor. My menu bar remained unreadable when I only adjusted the scale in gtkrc.

2
  • 1
    This is the correct answer on Windows. - Setting font_name to sans 16 is perfect on a 4k 43" desktop monitor. I guess a value of 20 or above would be more usable on 4k notebook displays. Gimp should really use a sensible default here based on system hidpi settings and not just fall back to the values which worked on 640x480 displays...
    – fviktor
    Mar 26, 2023 at 13:09
  • For me, "Sans 14" worked well on a 4K 49" display with Windows Display Settings scale at 100%. Yay! Gimp was practically unusable without this.
    – Martin_W
    Apr 12 at 3:12
1

In Windows 10/11, you have to edit the gtkrc file (This can be found [in the case of Dark theme] in C:\Program Files\GIMP 2\share\gimp\2.0\themes\Dark) of the theme you are using. Then you have to select that theme in GIMP's Preferences (Menu Bar >> Edit >> Preferences).

Changing the font-scale value wont increase the font size in the menus. You have to change the font size in two places and you have to uncomment the lines.

This part of the code has to be edited (It is found in the beginning):

#gtk-font-name = "Sans 11"

# KDE hack to match gtk/gnome defaults gtk-button-images = 0 style "gimp-dark-default-style"

{  #font_name = "Sans 11"

This is the edited version:

gtk-font-name = "Sans 20"

# KDE hack to match gtk/gnome defaults gtk-button-images = 0 style "gimp-dark-default-style"

{  font_name = "Sans 20"
0
0

The easiest way that worked for me to also change the menus text is:

Edit the file (in my case C:\Program Files\GIMP 2\share\gimp\2.0\themes\Dark\gtkrc)

Under the theme that you have chosen (could be Dark/Light/Grey/etc) in my case

style "gimp-dark-default-style" {

uncomment the line

  font_name = "Sans 11"

and add below

  GtkLabel::use-underline = TRUE

so it looks something like:

.
.
.
gtk-application-prefer-dark-theme = true

# gtk-font-name = "Sans 11"

# KDE hack to match gtk/gnome defaults
gtk-button-images = 0

style "gimp-dark-default-style"
{
  font_name = "Sans 11"
  GtkLabel::use-underline = TRUE

  color["clr1"]  = "#DDDDDD"
  color["clr2"]  = "#FFFFFF"
.
.
.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .