1

I'm running Arch Linux in my desktop with 4.19.91-1-lts kernel and packages are up to date.

I've first installed KDE Connect from pacman repository by using pacman -S kdeconnect and latest version of KDE Connect android app from Google Play Store Version 1.13.5 but when I try to pair the device I'm getting following error.

Error trying to pair: This device cannot be paired because it is running an old version of KDE Connect.

Error message

To try to remedy this situation I tried installing different version of Android KDE Connect app available in F-Droid both latest and old version but still it got me the same issues. I also tried other forums like here in manjaro and also followed community wiki of KDE connect. Then I tried recompiling KDE connect myself by using instructions from wiki but still have the same error.

By the way I've enabled the necessary ports as instructed here in ufw as well.

[biku@grim ~]$ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
1714:1764/udp              ALLOW       Anywhere                  
1714:1764/tcp              ALLOW       Anywhere                  
1714:1764/udp (v6)         ALLOW       Anywhere (v6)             
1714:1764/tcp (v6)         ALLOW       Anywhere (v6)

After vigorously surfing to different forums and madly duckduckingo and googling all said and done I'm still facing the same error and have no idea how to fix it. Any suggestions or recommendation will be highly appreciated.

0

First turn the UFW off and turn it on after you got kdeconnect up and working. What else have you tried? I guess both devices have a static ip in the same address range (192.168.0.? f.e.) and you can ping both devices? Some pairing problems occurred with custom roms like Havoc, is yours the original android? (Lineage OS works great, others might have problems)

Also it is possible that you need to accept some permissions to the kde app.

Sometimes, a corrupt config file may cause KDE Connect to crash when trying to pair with a device. In that case, deleting the config ~/.config/kdeconnect might help.

would be following command

 sudo rm -rf ~/.config/kdeconnect

Think its also worth a try.

Also you can pair in both directions, from the phone to the laptop and the other way around, maybe you just tried one way - also deleting the phone or the laptop in the gui might help, also a reboot of the phone and the laptop between deleting and reconnecting might help.

Hope one of that thoughts/solutions is already working for you, else leave a comment and I edit my answer.

Also a way to get a solution is the freenode irc #kde and #kdeconnect might give you some other ideas. (You can connect through matrix https://webchat.kde.org/#/room/#freenode_#kde:matrix.org)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.