All of a sudden, Win 10 Pro reports no sound devices available: The speaker icon in the lower right corner tells me that the speaker configuration is UNKNOWN, and in the win 10 sound setup, there´s no devices detected. However, in device manager all devices are where they should be: These are the onboard realtek sound devices and USB headphones, that have no exclamation marks and are all enabled.

The only thing I´ve done before this happened was to RDP into Windows from a Raspberry with WTWare, and reboot Windows FROM the Raspberry. Usually I don´t reboot this way but directly from the Win 10 machine itself, so I have the idea that maybe, but only maybe, the RDP connection somehow "stole" the audio service. Why? Because when on WTWare, the audio devices are not showing as available for output - all audio is then routed to a virtual audio device on the raspberry - which still works btw if I connect from the Raspberry.

What I have tried is to disable and then enable the onboard sound card in the BIOS, with reboots inbetween but this did not help. I did run the audio troubleshooter in Win 10 too of course, and every time it comes with no solution. It did however the first time tell me something about installing drivers and that I had to reboot, but this solved nothing. Obviously this is no driver problem, since it´s both the usb headset and the onboard audio card that is not being picked up by the sound settings in Windows.

What could be a solution for this?

  • Please view this Super User page and see if it helps superuser.com/questions/1213547/…
    – vssher
    Dec 30, 2019 at 18:50
  • Thanks, but as mentioned the audio still works on the raspberry. The host machine is the problem.
    – Corey Hart
    Dec 30, 2019 at 19:43

1 Answer 1


So, I dunno what caused my audio devices to no longer be considered audio devices in the audio management tool of Windows, but I solved the problem by doing a repair install from a fresh Win 10 ISO that I downloaded at the Microsoft homepage. Please note that the "keep all apps and personal files" was grayed out when trying with an older ISO, but this option was functional in the new one, being crucial for me to not have to install everything again. So far everything seems to run as it should, and the sound devices again are accessible for Windows to play through :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .