3

I'm trying to install Manjaro in this computer:

  • MB: ASRock Z75 Pro3
  • CPU: I3-3220
  • GPU: AMD Radeon HD 6800
  • RAM: 8GB
  • BIOS: UEFI American Megatrends ICN 2.00, 2013/10/9
  • SMBIOS version: 2.7.
  • SSD with two HDD in RAID as a slave
  • Windows 10

I've done the next actions:

  • I disabled SecureBoot
  • I disabled Fastboot
  • I have checked the ISO of Manjaro
  • I made the bootable USB again (Rufus and Etcher) with 3 different USB sticks.
  • I started with restart+shift (win) and selecting the UEFI USB Manjaro installation (and also the Legacy before)
  • I tried with Puppy Linux also and get similar results (when it is loading kernels in the installation process I get a black screen)
  • I tried with Puppy in DD mode (Rufus)
  • I checked that the disk is in a GPT mode
  • I tried with Arcolinux broking the PC (solved now)
  • I tried with nomodeset nolapic with watchdog BUG with both, free and non free drivers.
  • KDE Neon was installed very easy.

The best that I get is the Watchdog BUG.

Any idea?

EDIT: After so many tries I could install KDE Neon straightforward (I think clear CMOS helped to that), so I discard Manjaro for a while, at least until I see an easy way to do it.

26
  • When creating the USB in Rufus, does it prompt you to select "ISO mode" vs "DD mode"? Which one are you selecting? – user1686 Jan 1 '20 at 11:09
  • @user1686 Rufus doesn't give me that option. I saw some tutorials that suggest to use "DD MODE", but I haven't that option in my computer with my USB stick and the last version of Rufus. – AMGMNPLK Jan 1 '20 at 11:33
  • 1
    Try to add the following parameters to the Live boot : nomodeset nolapic (link). – harrymc Jan 7 '20 at 15:44
  • 1
    @AMGMNPLK: You may need to clear the CMOS. – harrymc Jan 8 '20 at 6:57
  • 1
    I assume that you are already installing Manjaro correctly, there aren't too many ways of doing it after all. ASRock computers are notoriously hard to install Linux, so I think that Manjaro is just not compatible enough. I'll add an answer. – harrymc Jan 8 '20 at 18:17
2
+50

The poster has not been able to install Manjaro Linux on his ASRock Z75 Pro3, although he did manage to install another Linux distribution, KDE Neon in this case.

The following steps made it possible:

Clearing the CMOS:

  1. Disconnect the system's power from the wall
  2. Press and hold the power button for 10 seconds to be sure residual power is discharged
  3. Place the "Clear CMOS" jumper in the clear position
  4. Remove the CMOS battery
  5. Leave the system in this state for 4 hours. 10 minutes is enough in most cases but if that yields no result then to be absolutely certain CMOS is clear I recommend 4 hours.
  6. Place the "Clear CMOS" jumper back in its original position
  7. Replace the CMOS battery
  8. Power on the system

Kernel boot options

The following was added to the kernel booting options : nomodeset nolapic.

Note: nolapic means having only a single cpu and core visible and should be disabled for later usage.

1
  • I installed without the nomodeset nolapic, but it works to run (with error) the installation of Manjaro that before didn't run. – AMGMNPLK Jan 8 '20 at 19:27
0

Can you please share the processor, memory and GPU (if any) you are using? From what you described it looks to me something to do with the kernel...

If you have an "old" kernel on the live iso, it may not have the correct drivers for your hardware. I can suggest you to download an [ISO of Arcolinux][1], they release monthly live ISOs so the user can test it and later perform the OS installation. It can boot on UEFI or MBR.

If this Arcolinux ISO boots it means your Manjaro or Puppy have a Kernel that doesn't recognize for some reason your hardware.

In case it does not boot, I'd like you to try to boot on MBR and share the results.

9
  • I've just edited the question with that info. I'm going to update the BIOS and after that take your advice. Thanks – AMGMNPLK Jan 7 '20 at 9:30
  • I got a blue screen after the update. I'm restoring the pc now. – AMGMNPLK Jan 7 '20 at 9:50
  • Sorry, I understand you got a Blue Screen after booting on Windows... Did you do any configuration on the Bios or just upgraded it? – vxp Jan 7 '20 at 9:51
  • Yes, blue screen trying to boot Windows after just upgrade BIOS. I'm going to try also with the Arcolinux because the restoring seems not to work, maybe I can skip the Windows restoration. – AMGMNPLK Jan 7 '20 at 10:04
  • The Win10 restoration looks like is working now. – AMGMNPLK Jan 7 '20 at 10:09
-1

Try a different USB device.

I don't see that in your list of troubleshooting efforts. I had somewhat similar results of Debian 10's installer only partially working, and in frustration one of my students tried a different USB stick and better results occurred. We could try to "made the bootable USB again (Rufus and Etcher)" multiple times over, but it turned out to be a hardware issue (solved by re-purposing that hardware to be a Memtest86 boot stick).

2
  • If you're selecting time zones, you've definitely accomplished what is typically the hardest part, so UEFI Secureboot settings are unlikely to be the issue. Persist. It sounds like you might just be a kernel parameter away from success. – TOOGAM Jan 4 '20 at 6:01
  • I have tried with 3 USB sticks. Any idea more? – AMGMNPLK Jan 4 '20 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.