0

What could explain remote desktop connection (RDC) failure depending on the client network? I have a RDC that uses my public IP, but the connection only works when the client is on the same network as the host. I would think that the client network would be irrelevant when using the public IP.

  • Remote desktop connections are enabled on the host.
  • The host firewall is letting RD through.
  • Port forwarding is set up on the router.
  • The whatsmyip.org port scanner shows that the RD port is open.
  • I set up the connection on two different Android devices.*
  • The connection uses the public IP (or a domain name set up through DDNS).

While a client device is on the local network, I can start the connection with no trouble. Then I disconnect and turn off the WiFi on the client so that it is using the wireless carrier network, and the connection fails with error 0x3000062 ("Remote Desktop Gateway is temporarily unavailable"). I have also tried this with the client on networks at shops around town and from work and always get the same error.

I saw in this question that the person said their ISP was blocking the port. The ISP claims that they are not blocking any ports. My router is behind a modem provided by the ISP, but they claim that the modem is not blocking anything.

*I do not have any other device to test with; I am trying to use the RDC to do work on an Android tablet while my laptop is being repaired.

7
  • 1
    Randy - In the Windows Firewall rule that allows Remote Desktop connection inbound via TCP, check the Advanced tab of the rule and in the "Profiles" section, ensure that all Domain, Private, and Public are checked. This might solve the problem but let me know if it does and I'll write up in an answer why, etc. with more detail and make it look pretty and such too!!! i.imgur.com/BrWIQmS.png Jan 4, 2020 at 1:56
  • Those were already checked. Jan 4, 2020 at 4:17
  • Linksys EA7500 (AC1900). I have the router assign the host network card a static IP and allow TCP and UDP through port 3389 to that IP (and I have verified that RD on the host is trying to use that port, but I do not quite know enough to figure out if the Android client is doing something different). Wouldn't the router have to let the connection through from the internet even if the client is on the same network (because I am using the public IP)? Jan 5, 2020 at 2:12
  • I think it's called NAT loopback or hairpinning. Jan 5, 2020 at 2:26
  • Randy, Go to these settings per this screen shot assuming this is what the configuration looks like.... i.imgur.com/hch9Omb.png and be sure to configure the rule as I put in red and black for the port forward rule. Put in the private IP of the RDC server/PC you are connecting via RDP to though. I assume this is how you are trying to do it but see if this helps. Jan 5, 2020 at 2:33

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.