4

I am having this problem since a few months:

on my home PC (windows 8.1) when I start the Skype desktop app, it logins into my Skype account, but after a second it logs out and shows the starting dialog (see screenshot below), where I must enter my account name and password again to log in. Then everything works until the next time I start Skype when the same problem happens again.

The showed login dialog:

enter image description here

At that time, the Skype credentials disappear from Control Panel / Credential Manager (where they are usually stored and visible, when the Skype login works - see below an example):

enter image description here

I use the same Skype account on my iPhone and iPad and work PC (Windows 7) and there is never an issue.

I tried:

  • reinstalling Skype
  • clearing all saved state, including the Skype login credentials in Windows Credential Manager
  • updating the Skype app (several updates were released in that time)

Nothing helps.

The only thing I found was a workaround:

  • start Windows
  • login to Windows
  • open Control Panel / Credential Manager
  • start Skype

I am doing this since a month, and it never fails. Today I started Skype without opening Credential Manager first, and bam, it logged me out again.

Currently I have Skype version 8.55

For reference, this is how Credential Manager looks when my Skype login is remembered:

enter image description here

There is a reddit discussion about this here and there a discussion on Microsoft Skype community forum is linked, with some users having the same problem, but no solution.

8
  • Try to run Skype once as Admin, enter credentials, and then exit.
    – harrymc
    Jan 7 '20 at 17:23
  • Try to remove your microsoft account completely from windows, log in again. I think it should work then
    – Srinivas V
    Jan 8 '20 at 17:21
  • @SrinivasV I have no microsoft account. Jan 9 '20 at 11:59
  • @DavidBalažic: Did you try to run Skype as Admin?
    – harrymc
    Jan 10 '20 at 7:48
  • @harrymc it will take several days to see if that helped. Jan 10 '20 at 13:13
1
+50

Try the old fix of running Skype once as Administrator, entering fully the credentials, then exiting and passing on to normal running.

This trick allows the program to update some parameter that it is stuck on trying to update, but cannot manage to do because of some snarl-up of permissions, and this may also reset those permissions.

This trick has worked for me, although for other products, and may also work for Skype.

5
  • awarding bounty, even if not tested yet (in past it worked fine for days, and then logged out, so it is hard to tell if something actually helped or not). Jan 13 '20 at 10:34
  • It didn't help. I started Skype as Administrator on 18.2.2020 and today, on 29.2.2020, so only 11 days later it logged me out after start. Feb 29 '20 at 14:11
  • I understand then that it did work for 11 days. You could try to redo this, if whenever and whatever is the problem happens again.
    – harrymc
    Feb 29 '20 at 14:15
  • No, the same thing happened without running as Admin. It works OK for days, then one day stops. Running it as Admin did not make any difference. Feb 29 '20 at 22:36
  • Did you try to uninstall Skype, scrub the disk and registry for every mention of the string "Skype", then reinstall?
    – harrymc
    Mar 1 '20 at 7:15
0

Skype for Desktop MSA/david.balazic

  • username
  • password

Skype for Desktop/david.balazic

  • username
  • password

david.balazic

  • username
  • password

now enter also another with just the username

  • username
  • password
1
  • How? If click "Add a generic credential", I must also enter "Internet or network address". Jan 10 '20 at 19:39
0

This helped me out:

  1. Uninstall Skype
  2. Go to ...\AppData\Roaming directory (press Windows + R and type %appdata% then enter)
  3. Delete (or rename) 2 folders: Skype and Microsoft\Skype for Desktop
  4. Reinstall Skype

I found out that the size of old Microsoft\Skype for Desktop\Cache folder was too big, which could be a core reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.