2

I have just installed a fresh windows 10 v1909. Having installed some apps, I activated bitlocker. Bitlocker warned me saying "something" about a recovery partition not existing and how it can be made manually if needed. When I went to disk manager there indeed was no recovery partition and all of my advanced startup options were reduced to boot options. No command prompt, no restore points... How do I remake a recovery partition that windows usually automatically creates and how do I return all of the options to WinRe/Advanced startup? Edit: I would also like to add that the System reserved partition no longer exists and the one from which windows boots is unnamed.

0

1 Answer 1

6

PCs with BIOS motherboards are often configured without a WinRE partition, instead storing WinRE on the Boot or OS partition

WinRE should always be on its own partition, but only Win ≥10 clean installs do so:

  • Windows ≥10: \\WinRE_partition\Recovery\WindowsRE
    (Upgrade: C:\Recovery\WindowsRE)
  • Windows ≤8.1: C:\Recovery\WindowsRE

To move WinRE to its own partition: (ReAgentC)

  1. Open an Admin Terminal: WinKey+ROpen: powershellCtrl+Shift + OK
  2. Backup current winre.wim:
    1. Verify %WinDir%\System32\Recovery\winre.wim exists:
      ls "C:\Windows\System32\Recovery" | FindStr /I "winre.wim" ; ls "C:\Windows\System32\Recovery" -Hidden | FindStr /I "winre.wim"
      
    2. If it doesn't:
      Xcopy /H "C:\Recovery\WindowsRE\winre.wim" "C:\Windows\System32\Recovery"
      
      • BIOS: May store WinRE on Boot partition: Mount Boot at Y: → Update WIM path
        (Once copied over, remove Y: mountpoint: DiskPartSel Vol YRemove)


  3. Create a 650MB WinRE partition: WinKey+ROpen: DiskPart → OK
    ::# WinRE partition should have ~300MB free for future winre.wim size increases
    
    ::# Select OS partition: 
    sel vol c
    
    ::# Shrink partition by 665MB [RAW]:
    shrink desired=665 minimum=650
    
    ::# Create WinRE partition:
    
        ::# BIOS:
        cre par pri size=665 id=27
    
        ::# UEFI:
        cre par pri size=665 id=de94bba4-06d1-4d40-a16a-bfd50179d6ac
        gpt attributes=0x8000000000000001
    
    ::# Format partition:
    format fs=ntfs quick label=WinRE
    
    ::# Mount partition:
    assign letter=z
    
    exit
    

  4. Disable WinRE, set custom location of winre.wim, and re-enable WinRE: (ReAgentC)
    # Copy WinRE.wim:
      MkDir "Z:\Recovery\WindowsRE" ; Xcopy /H "C:\Recovery\WindowsRE\WinRE.wim" "Z:\Recovery\WindowsRE"
    
    # Disable WinRE:
      ReAgentC /Disable
    
    # Set Custom WinRE Path:
      ReAgentC /SetREimage /Path "Z:\Recovery\WindowsRE"
    
    # Enable WinRE:
      ReAgentC /Enable
    
    # Verify:
      ReAgentC /Info
    
    # Remove WinRE mount point:
      DiskPart
        sel vol z
        remove
        exit
    

11
  • So the WinRE mountpoint is now removed, but windows defragmenter recognizes the partition as a separate drive. It also now recognizes the system reserved boot partition. Is it possible to hide them like windows does normally?
    – Enforcer
    Jan 6, 2020 at 15:01
  • For that, I don't have an answer. Do you have a BIOS motherboard or UEFI? BIOS: setting the WinRE partition ID to 0x27 (#3.3) identifies it as a special Windows Recovery partition, whereas w/ UEFI, the same is set via GPT ID de94bba4-06d1-4d40-a16a-bfd50179d6ac, w/ partition being hidden via GPT attribute 0x8000000000000001 (#3.6). I don't have a BIOS PC to troubleshoot with DiskPart (verify DiskPart is showing the ID - lis vol > sel vol <#> > det vol), so you're likely going to need to refer to Microsoft Docs, or create a second question on SuperUser for this specific issue
    – JW0914
    Jan 6, 2020 at 15:17
  • @Enforcer I've just checked my own PC and w/ UEFI, the WinRE partition is shown in Disk Defragmenter (likely because it's formatted NTFS)
    – JW0914
    Jan 6, 2020 at 15:23
  • Perhaps it is visible because I'vs set it up as id=27 instead of 0x27?
    – Enforcer
    Jan 6, 2020 at 15:26
  • I have checked it out with "det vol" and it says that it isnt hidden.
    – Enforcer
    Jan 6, 2020 at 15:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .