3

I am using Cygwin64 on Windows 10 to download files via Wget from NASA’s Earthdata website. I seem to be following the correct procedure as explained on their website, but for some reason, Wget is not downloading the files. I just see a blinking cursor.

wget -q --spider machine urs.earthdata.nasa.gov

touch .netrc

echo "machine urs.earthdata.nasa.gov login baloch444 password *********" >> .netrc

touch .urs_cookies

wget --load-cookies .urs_cookies --save-cookies .urs_cookies --auth-no-challenge=on --keep-session-cookies --content-disposition --no-check-certificate --user=baloch444 --ask-password -I myfile.dat
5
  • 1
    have you tried the obvious.. do wget http://blah/blah.html See if that works no blinking cursor. Then try adding stuff. Then that may help you figure out what is wrong with your command
    – barlop
    Jan 6 '20 at 3:39
  • 1
    Why are you using machine urs.earthdata.nasa.gov instead of the more basic, https://urs.earthdata.nasa.gov? So your command would be wget -q --spider urs.earthdata.nasa.gov`. Also, what version of Wget are you using? Their site mentions differences between how to use Wget 1.11.1 and higher versus Wget 1.11 and lower. Jan 6 '20 at 3:57
  • 1
    Yes, Jake you are right, machine was causing the problem, I changed it to https, and it's working now. Thank you for your help. Jan 6 '20 at 4:15
  • 1
    @JakeGould can you post that as an answer for Saad to accept? Thanks Jan 6 '20 at 7:29
  • @Saad Answer posted. If it helped you, please be sure to upvote it. And if it is the answer that solved your problem, please be sure to check it off as such. Jan 7 '20 at 15:08
3

Why are you using machine urs.earthdata.nasa.gov instead of the more basic, https://urs.earthdata.nasa.gov? So your command would be

wget -q --spider https://urs.earthdata.nasa.gov

Also, what version of Wget are you using?

Their site mentions differences between how to use Wget 1.11.1 and higher versus Wget 1.11 and lower:

“Note: Starting with version 1.11.1, Wget requires the --auth-no-challenge option to authenticate properly to URS. Versions prior to 1.11 should omit the --auth-no-challenge option. Version 1.11 of Wget will not work at all.”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.