6

On my company's intranet, there are about 10 different urls using the same login page. The login/password is different for each one of them. I saved my password for each url on firefox. They all have the same login but the password can (an often does) vary. They were all created at different times.

But recently, on any page of the portal, firefox started to suggest a list of passwords used on other sites. Why is that? It used to just suggest the password for the page I'm on.

firefox_password

Here's the translated French :

  • The top part is the "This connection is not secure" message.
  • next to the key is my username, the same for all passwords
  • "Depuis ce site web" is "From this website"
  • the blackened lines below are all the urls of similar pages (different urls but maybe firefox thinks it's a single website. And by url I mean the host and port are different, not just the filepath. They're entirely different servers.)
  • the text at the bottom is something like "Show saved logins". It shows only the one for the current url, and not the list of suggested logins like I expected.

How can I make this long, unnecessary list go away and why did it start appearing?


Firefox is not synced to an account on this computer.

3
  • 1
    Do you use Firefox latest or the ESR releases? There is an setting in about:config that can disable this behavior: Set signon.includeOtherSubdomainsInLookup = false. The rest of your description sounds like this bug: bugzilla.mozilla.org/show_bug.cgi?id=1556953 – Robert Jan 6 '20 at 18:13
  • @Robert Thanks, that worked! Is there any side effects of turning that off though? – Teleporting Goat Jan 7 '20 at 10:30
  • Of course it has side-effects. If disables the saved passwords on any subdomain that does not match the domain it was originally entered. Therefore if a web site changes the domain of it's login page (e.g. login.example.org to authenticate.example.org or it has multiple subdomains for authentication) Firefox will no longer offer the password. – Robert Jan 7 '20 at 10:55
7

You can configure Firefox to ignore passwords entered on other sobdomains of the crrent domain.

To do so open the advanced configuration page about:config and change the value

signon.includeOtherSubdomainsInLookup = false

If hides all passwords on any subdomain that does not match the domain it was originally entered.

1

You can also remove the top part of that message "Cette connexion n'est pas sécurisée...", if you want to; by setting

security.insecure_field_warning.contextual.enabled

to false.

1
  • Could you explain how the OP would go about changing this setting? – Burgi Feb 13 '20 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.