12

When I attempt to start an Ubuntu guest OS in VirtualBox it gives me this error:

Call to VidMessageSlotMap failed: Last=0xc000000d/87 (VERR_NEM_VM_CREATE_FAILED)

I was getting more common errors (AMD-V) relating to virtualization beforehand. I am aware of issues with Windows 10, AMD, and virtualization. I had enabled SVM Support in the BIOS and it solved those issues, but this one is now appearing which it didn't before.

When I search this error I get information relating to "WHvSetupPartition" and not "VidMessageSlotMap". I tried the fixes for that (including the powershell command: bcdedit /set hypervisorlaunchtype off) with this one too, but they didn't work.

"Your question has been identified as a possible duplicate of another question." As mentioned, it's a different error and I've tried fixes for that error on this too.

I am using Windows 10 Pro N, a Ryzen 5 1600, and a Gigabyte B450M DS3H. As I said I enabled SVM in the BIOS and I am sure to have disabled the Windows 10 based virtualization features as they were apparently causing issues too. I attempted with them both enabled and disabled.

enter image description here

I've highlighted the ones I've heard are the ones that may conflict with it and as you can see they're all disabled.

What is causing this and how do I disable it or prevent it from doing so? Or what may I need to enable to get this working?

8
  • 4
    Does this answer your question? VirtualBox fails to start with VERR_NEM_VM_CREATE_FAILED
    – Ramhound
    Jan 6, 2020 at 23:57
  • 1
    @Ramhound - It doesn't help because it talks about a different error: "Call to WHvSetupPartition failed", whereas this one is "Call to VidMessageSlotMap failed", and I've mentioned this and how I still tried the same fixes to no avail in the OP. As the screenshot shows I have disabled all the Windows 10 virtualization, along with restarting multiple times. I don't get any other errors than what VB shows, however what other software may be (somehow) still using it as I haven't used virtualization on this machine before? Thanks.
    – Jezza
    Jan 7, 2020 at 17:27
  • You should also verify you are NOT using an Insider Preview build of 20H1 or 20H2.
    – Ramhound
    Jan 7, 2020 at 17:38
  • I was able to install it with Windows Subsystem for Linux checked. The others I also had to uncheck because neither VirtualBox nor Intel HAXM could be installed. But apparently, your issue is beyond that.
    – CristiFati
    Jan 17, 2020 at 10:08
  • 1
    I got this same error today after I installed Docker Desktop on Windows.
    – nassim
    Jan 30, 2020 at 13:52

5 Answers 5

3

I was getting the same error. Leaving Virtual Machine Platform on made VM run.

4
  • Yeah I tried this and it worked, thank you. Also was able to enable Windows Subsystem for Linux and it still worked.
    – Jezza
    Jan 18, 2020 at 21:19
  • No, didn't work for me, it just disabled my interet connection!
    – quilkin
    Apr 26, 2020 at 13:59
  • 3
    What is "Virtual Machine Platform", and how do I leave it on?
    – Jake Levi
    May 5, 2021 at 16:51
  • 1
    @jake, its a windows feature, in the windows search bar search "turn windows features" Mar 16 at 20:07
3

My problem was started when i have enable WSl2 in windows 10 machine. But i am able to run WSL2 and Virtual Box by following steps:-

  1. Open Virtualbox
  2. Click on File Menu
  3. Select Check for update
  4. This will download a file in your downloads
  5. Click on downloaded file and follow the steps

My error is gone after installing below version. Version 6.1.16 r140961 (Qt5.6.2)

Happy troubleshooting.

1
  • 1
    Thank you this should be top comment
    – qz-
    Apr 25 at 17:37
1

I had exactly the same error :

Call to VidMessageSlotMap failed: Last=0xc000000d/87 (VERR_NEM_VM_CREATE_FAILED).

I resolved this with a second reboot of the system. Hyper-V functionality and Windows containers were already disabled:

Disable-WindowsOptionalFeature -Online -FeatureName containers

I use French Windows 10 Pro. I have none of the following items: "Vitual Machine Platform", "Windows Hypervisor", "Windows Sandbox", "Windows Subsystem for Linux".

0
  1. Try to update Windows to latest version and install latest version of VirtualBox (& if you used, you can update ExtensionsPack too)

  2. if above doesn't solve, try https://forums.virtualbox.org/viewtopic.php?f=6&t=95978

0

I faced this issue after installing Docker Desktop and here is how I resolved this issue.

  • Open the "Turn Windows features on or off" settings (type optionalfeatures in the start menu or Win + R).
  • Uncheck "Windows Machine Platform" and "Windows Subsystem for Linux" .
  • Restart windows once or twice.

enter image description here

enter image description here

  • If you have Docker Desktop installed, then after restart you will see the following message.

enter image description here

I think the above message is telling that you have to check Windows subsystem for Linux and Virtual machine Platform for running Docker Desktop.

If you want to work on Docker Desktop again, you can check these options a see that are you able to use Docker Desktop or not. I haven't checked it myself so I can't tell you the result.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.