Recently I purchased an ADATA C802 8GB flash drive. Since the drive was new I decided to run some of the HD Tune Pro (v4.50) performance tests on it, mostly just for the heck of it.

To avoid accidentally destroying data HD Tune refuses to write to a drive unless there are no partitions on the drive. If you do attempt to write to a drive with partitions, it posts the message "Writing is disabled. To enable writing please remove all partitions."

As you would expect, the ADATA came formatted with a single primary FAT32 partition in the Master Boot Record. But a number of unexpected things happened when I attempted to delete that partition.

  1. The first thing I tried was to use the Windows 7 (64-bit) Disk Management tool (diskmgmt.msc) to delete the partition. It would not let me. The context menu choice to delete that volume was not available.

  2. Next I opened up a command prompt window with Admin authority and ran diskpart. Diskpart deleted the volume for me. However, when I attempted to run an HD Tune write test on the drive I still got the "Writing is disabled" message. Huh???

  3. So I fired up a utility I happen to own which allows viewing drives at the sector level and verified that the partition table in the Master Boot Record was empty. No partitions. Yet HD Tune still thought there were partitions on the drive?

So why was I still getting the "Writing is disabled" message from HD Tune Pro? And why wouldn't the Windows 7 Disk Management tool let me change the partitions on this drive.

After doing the above, I plugged the ADATA into my MacBook. I was then able to format it as either a GPT or MBR partitioned drive with no problems. I am not looking for suggestions on how to format this drive. I can do that.

What I do not understand and was hoping I might get insight into is why this drive behaves so strangely under Windows 7? And BTW, what's up with HD Tune Pro?

BTW, if I plug the drive I formatted on my MacBook back into my Windows 7 64-bit system I still run into road blocks with the Disk Management tool. For example, I cannot delete all the GPT partitions on the ADATA so I can convert it into an MBR drive. I followed Microsoft's instructions, the instructions just do not work with this ADATA flash drive.

Anyone know what's up with this? It makes no sense to me. Has something changed in Windows 7 (Vista)??

  • 7
    With DISKPART, select the disk, and run CLEAN. Then try to use the benchmark. Let me know if that solves it. Commented Aug 22, 2011 at 17:57
  • 1
    I tried DISKPART and I got an error on CLEAN after selecting the disk: DiskPart has encountered an error: Incorrect function. See the System Event Log for more information.
    – travis
    Commented Jan 25, 2012 at 6:57

4 Answers 4


There's no need to install any third-party programs, Windows already includes everything you need. Just open up command prompt and enter the following commands in sequence:


Select the disk that you want to correct. Example: I want to remove all partitions on Disk 1:


If the CLEAN command doesn't work, try RECOVER.

Disk 1 will be recovered as one complete disk.

FORMAT <option>

Where <options> represent what formatting method you'd prefer. Alternatively, use QUICK.

  • 5
    This is almost correct. For correct answer, see superuser.com/questions/536813/…
    – Gnudiff
    Commented Jun 8, 2014 at 13:12
  • 2
    In my opinion (and in my experience 30 seconds ago), this IS the correct answer. Commented Sep 10, 2014 at 3:51
  • 5
    RECOVER was successful, but CLEAN was what I needed.
    – kevlar1818
    Commented Dec 3, 2014 at 20:39
  • 2
    what's the difference between recover and clean?
    – Rachael
    Commented Aug 4, 2015 at 6:30
  • 1
    recover didn't do anything for me. clean worked great. good stuff.
    – Joe Healy
    Commented Dec 16, 2015 at 15:29

Try the software MiniTool Partition Wizard.

I've used it before to create and delete partitions on flash media. It may work for you, and it's free.

MiniTool Partition Wizard Home Edition is a free partition manager software designed by MiniTool Solution Ltd. Our partition manager supports 32/64 bit Windows Operating System including Windows XP, Vista and Windows 7. Home users can perform complicated partition operations by using this powerful yet free partition manager to manage their hard disk. MiniTool Partition Wizard Home Edition is designated for home user only.

  • Support Windows 2000/XP/Vista/windows 7 (32 bit & 64 bit) operating system.
  • Support RAID.
  • Extend system partition to maximize computer performance.
  • Manage the hard disk for substantial performance increase.
  • Create, Delete and Format partitions with simple steps.
  • Disk Copy to protect or transfer data.
  • Support disk and partition size larger than 2 TB.
  • Convert partition format from FAT to NTFS.
  • Partition Copy: Copy the entire content of one hard disk to another.
  • Copy Disk Wizard: Copy the entire hard disk to another without having to reinstall Windows.
  • Disk Map - Visually demonstrate your disk/partition configuration; preview the changes before applying.
  • Hide/unhide partition, set active partition, etc. - Change partition properties easily.
  • Explore FAT/NTFS partition.
  • Set partition as primary.
  • Set partition as logical.
  • Rebuild MBR.
  • Disk Surface Test.
  • Partition Surface Test.
  • Change Partition Serial Number.
  • Change Partition Type ID.
  • Hot Extend Partition without reboot. NEW!

enter image description here


I found a simple solution because I had the same problem with HDD Tune Pro.

Just format the card or USB flash drive to NTFS, and then you can delete that NTFS partition using EASEUS Partition Manager without restarting, and voilà, I was able to test write speed with HDD Tune Pro.


If you can't find anyone who knows how to fix this problem on Super User, it would be worth contacting A-Data themselves at their Support Center.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .