1

For several years with Windows 10 I have been using Cortana to find a file by name, and then open the file location in Explorer.

For some months now the only right-click option has been "Open in Browser".

Search result gives option to open in Browser

This really bugs me, because the browser is slower for file operations (rename, etc), and I'm stuck with a browser app to open the file.

A possible factor may be that the search results are typically from a cloud location, ie. OneDrive. However they are seen as a local drive on my computer. If Cortana finds a file which is strictly on a local drive then a right-click gives me the option to "Open file location"

enter image description here

To investigate, I've searched for advice on Cortana, its settings and search results, and the typical advice is how to select the browser (Edge or Chrome, etc.) for the search results. The Cortana settings don't seem to have anything related to this.

How do I restore the old option to open in Explorer?


And this is what it looks like now that it's fixed:

enter image description here

== Edit, July 2020 ==

It seems to have been a Windows 10 bug. The fix described below didn't work for long, but the problem has just gone away for a couple of months now. File search results from Cortana now give the option to open in File Explorer, it's the first option, and it works (ie. doesn't open in the browser).

1
+50

I would suggest to Reinstall and Re-register Cortana.

To do so for all users:

  1. Open an elevated PowerShell

  2. Copy and paste the command below into the elevated PowerShell, and press Enter. (see screenshots below)

    Get-AppxPackage -AllUsers Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    
  3. A message saying "Deployment operation progress" will appear. Once the process is completed, then Cortana is installed.

4
  • It worked! Thanks! The first time I got an error. I closed all apps and stopped Cortana with the Task Manager, but got the same error. I restarted the PC, and got the same error. I closed Cortana with the Task Manager and Cortana re-appeared immediately, but next time I tried the command it worked! Happy! – Stephen Hosking Jan 14 '20 at 10:44
  • So, it's a working solution, but would be better without the error, or a reliable way to remove the error. I felt the way I got there was a bit "lucky". I'll award the bounty if nothing better appears. – Stephen Hosking Jan 14 '20 at 10:47
  • 1
    Windows is funny this way, and may sometimes require booting a couple of times before everything returns to its right order. It might even be required to repeat the above procedure twice, for all components to return truly to their correct state. – harrymc Jan 14 '20 at 10:51
  • The link you gave mentioned this problem, and the solution was to "Repair Install Windows 10 with an In-place Upgrade". At least I didn't have to go that far. Thanks for the extra comment. – Stephen Hosking Jan 14 '20 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.