I tried this answer, but it broke my Gnome Terminal, with this error message:

There was a problem with the command for this terminal
Text was empty (or contained only whitespace)

I tried reinstalling it and uninstalling/reinstalling it to no avail. Anyone have any ideas how I can fix this? I really need my terminal ;-)

EDIT - I should clarify... Before the terminal broke, I could spawn a new terminal with the command:

gnome-terminal --geometry 120x30

It broke after I placed the same command but with an "=" in the config settings and saved it. It just so happens that I had a working terminal open when all this happened and it is still functioning fine, indicating that the terminal works OK, but the launcher is corrupted.

  • that exact command works for me on the commandline to spawn a new gnome-terminal of the specified size and position. haven't tried adding that to the startup program list, but i'm on 10.04 so your problem may be 9.10 specific. does it work for you if you execute it on the commandline? – quack quixote Jun 11 '10 at 20:56
  • See my EDIT above... I could spawn the terminal too from the command line. – nicorellius Jun 11 '10 at 23:55
  • @quack - I actually run both karmic and lucid, as a dual boot system for testing purposes. I mainly run 10.04. The funny thing is, 10.04 has the option in the GUI to set this exact parameter. I wonder if I could transfer the gnome-terminal from lucid to karmic? Would that work? – nicorellius Jun 12 '10 at 1:14
  • i'm not sure what you mean by "broken". you mean any gnome-terminal won't start now? or just ones that use the --geometry=... argument? – quack quixote Jun 12 '10 at 1:49
  • Broken as in the terminal wont start and is accompanied by the error in my original question. The window actually opens, but there is no prompt and typing in the window is unresponsive. But I fixed it anyway, so the point is moot. – nicorellius Jun 12 '10 at 2:01

I fixed this by un-checking the box by an option, under Profiles > Title and Command, called "Run as a custom command instead of my shell." This was checked when I altered the custom option under System > Preferences > Preferred Applications, System tab. I still haven't figured out how to make the custom configuration stick, but I at least found a way to fix my terminal when I experiment with tweaking it.

EDIT - Also, the reason the original error said Text was empty (or contained only whitespace) was because when the checkbox was checked, the command was missing (under Profiles > Title and Command). So, thinking I could simply add the command and actually use the "Run as a custom command instead of my shell" I entered gnome-terminal --geometry 120x30 and clicked close. Then when I opened the terminal, it started to freak out and it appeared like the terminal was being launched repeatedly, very quickly. @quack, if you happen to try this as well, maybe you could explain this odd behavior?

What fixed the problem and serves as this answer:

I edited the /usr/share/applications/gnome-terminal.desktop file with the Exec=gnome-terminal --geometry=120x30 line and this finally gave me what I wanted...

  • wait. you checked the "run as custom command" setting and entered gnome-terminal as the command??? you made it recursive. it broke because every time gnome-terminal started, it tried to run the command gnome-terminal, which tried to run the command gnome-terminal, which .... should have resulted in a stack overflow of gnome-terminals. ish. that's the theory, anyway. not something i'll be testing out, tyvm. :) – quack quixote Jun 12 '10 at 3:04
  • I know, I know... Very rookie mistake! So I finally edited the /usr/share/applications/gnome-terminal.desktop file with the Exec=gnome-terminal --geometry=120x30 line and this finally gave me what I wanted... Thanks for drilling me appropriately for doing something stupid ;--) I know realize why you wouldn't want to test this on your system. – nicorellius Jun 12 '10 at 3:08
  • you said you followed the procedure from this answer, but that's not really what you did, was it? nowhere in the question or the comments had you mentioned that you set "run as custom command" that way. next time be explicit about what you've done, what you've tried and what's happening. – quack quixote Jun 12 '10 at 3:10
  • Actually it was exactly what I did... it caused the original error (the one in my original question). Only in my answer did I mention the Profiles > Title and Command set of steps and the fact that the recursive behavior was an additional problem. I explored the behavior as I progressed through asking the question and, subsequently, answering my own question. – nicorellius Jun 12 '10 at 3:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.