1

I had Firefox 71 installed on my Fedora 31. When I updated to Firefox 72 almost all web sites stopped loading, I observed only empty pages instead of web sites. The only workaround is to use another browser (for example Chromium) or downgrade to Firefox 71. After searching a bit I only found a similar issue for ArchLinux with the same workarounds: https://bbs.archlinux.org/viewtopic.php?id=251955. Also there is an old bug https://bugzilla.mozilla.org/show_bug.cgi?id=1591374 but it seems that it is irrelevant.

Are there any workarounds for the latest 72 version?

2
  • I am posting this comment with FF72 in ArchLinux. No issue on my side. Try to use a new profile in Firefox. Or try to move the configs to different location so that Firefox creates a new one.
    – Biswapriyo
    Jan 9 '20 at 16:34
  • I have 72.1 updated this morning (Windows 7 Pro) it is working fine
    – vssher
    Jan 9 '20 at 17:40
3

Turns out that Firefox 72 is somehow incompatible with nss (Network Security Services) package version 3.47.1. After update of nss from 3.47.1 to 3.48.0 Firefox 72 started working. The solution is to update nss:

sudo dnf update nss
3
  • Yeah, looks like a missing dependency. Generally, all Fedora updates should applied at once and cherry-picking can lead to surprises.
    – mattdm
    Jan 10 '20 at 15:47
  • I applied all security updates with sudo dnf update --security so it was not a Firefox only update. Looks like a broken dependency or Firefox bug refusing to work with previous versions of nss.
    – ks1322
    Jan 10 '20 at 16:00
  • Yeah, the corresponding nss update probably should have also been marked as security to avoid that. The firefox package maintainer is updating the spec file to mark the new requirements. The --security option isn't quite cherry-picking but is subject to this same risk — it's hard to always catch these things in advance.
    – mattdm
    Jan 10 '20 at 16:02
0

Go back to V71 at this point. My Ubuntu 18.04 system is fully up to date and Firefox is V71. My Kali System is fully up to date and Firefox is V68 LTS. Any attempt to update fails.

So stay at V71 until Firefox fixes its version issues.

5
  • As I understand Firefox 72 is not yet released on Ubuntu: bugs.launchpad.net/ubuntu/+source/firefox/+bug/1858504.
    – ks1322
    Jan 9 '20 at 17:54
  • I don't think V72 is yet released for all versions, so I do suggest waiting
    – John
    Jan 9 '20 at 18:04
  • 1
    -1 because what you describe is not related and not an issue at all. Availability of newer FF versions in default repositories of OSes is not Firefox team's responsibility. You couldn't update because newer versions weren't released by their respective maintainers. (FF 72 is available on Ubuntu 18.04 as I'm writing this). That's not the issue OP described.
    – gronostaj
    Jan 10 '20 at 10:51
  • Disagree. The new version does work across all systems yet, so my answer WAS related. I will try this weekend but as of 12 hours ago, V72 would not install. There was nothing wrong with suggesting to wait for a bit.
    – John
    Jan 10 '20 at 13:00
  • Given that there's a rather serious security issue known to be exploited in the wild, waiting does come with some extra risk. Also, as noted in the other answer waiting is not necessary on Fedora — just make sure you update nss (or apply all available updates) as well.
    – mattdm
    Jan 10 '20 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.