90

I've associated .xul with Notepad++ so if I double-click on a .xul file, it will open in Notepad++. But Notepad++ doesn't know that XUL is just a particular type of XML, so I then have to manually click on "Language > XML" to get XML syntax highlighting. Is there a way that I can tell it: "every time you open a file with the extension .xul, automatically switch to the XML language"?

121

All you have to do is tell Notepad++ that "xul" files are actually "XML" files.

  1. Go to Settings > Style Configurator
  2. Under Language, scroll down and highlight "XML"
  3. At the bottom, under User ext. type in "xul"
  4. Press Save & Close
  5. Open your file and it should now highlight properly.

Some other helpful links:

  • 17
    And if you want to add more than one (for example, I'm also adding 'rdf' -- yup, I'm doing Firefox extension development) then just separate them with spaces. – MatrixFrog Jun 11 '10 at 22:21
  • 1
    I'm saving it and it works for the session but it doesn't persist. When I restart Notepad++, it's not there anymore. – strider Mar 27 '14 at 15:31
  • 4
    Run it as Administrator and it persists. – strider Mar 27 '14 at 15:37
  • 3
    Note that for user-defined languages, the same can be done from the language configuration window in Language > Define your language... > user language : <your language> in the Ext. field. – yco Apr 20 '16 at 9:54
  • Awsome! +1 for you! – Ivijan Stefan Stipić Nov 11 '16 at 17:55
4

Here is the instructions for user defined languages. With pictures.

Select: Language --> Define Your Language:

Select: Language --> Define Your Language

Make sure you omit "." from extension in the Ext. box, or it wont work:

Make sure you omit "." from extension in the Ext. box, or it wont work.

  • 1
    Please read the question again carefully. Your answer does not answer the original question. This is an answer to some other question. – DavidPostill Jan 29 '17 at 15:35
  • And yet it is very useful. Often when searching for a specific question you will find a more generic question. That's what happened to me. The first answer didn't solve my problem because I was looking for a slight variant of the issue (a user defined language). This answer helped me where the accepted one did not. – Scott Beeson Feb 21 at 14:29
0

Update for version 7.5+ and for multiple extensions

1) Settings > Style Configurator

2) look under "Languages:" , choose your target language.

3) look at textbox under "User ext. :"

Simple type the extension you wish to associate for that language. For multiple file extensions, it should be separated via SPACE. Do not use any "." period/dot characters.

EG. for SQL i used the following extensions for table, view, stored proc and user defined functions:

tab viw prc udf
  • The only thing that I can see that you’re adding to the accepted answer is that the user can specify multiple extensions, separated by spaces — and that was posted as a comment to the accepted answer nearly nine years ago. – Scott Feb 18 at 0:56
  • @Scott Obviously, the multiple extension was the answer i was looking for that was not provided by the answer. I even indicated it in my first sentence. And the separator which is space is not even common parlance which is normally comma or semicolon. Either way i had to dig in further just to extract the answer. The box is also misleading because it is SMALL looking as if it can only support 1 extension. If you don't appreciate this kind of input, then whatever. – Earl Feb 18 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.