4

i'm running windows 10 pro (1909) on a domain-joined machine.

when i do a RDP session (mstsc.exe) into that machine and trying to launch a certain program i'm getting the error:

LoadLibrary failed with error 87

enter image description here

however, when i log on locally there is no such problem with launching that program!

any ideas?

5 Answers 5

5

after some searching on the web it turned out to be a problem with the driver of my specific graphics card by AMD / ATI.

in my case it's an AMD FirePro W2100 (FireGL V).

i have followed the suggestions on the web to simply rename:

%WinDir%\System32\atig6pxx.dll

into:

%WinDir%\System32\atig6pxx.dll.bak

this made the error disappear!
i just hope that this approach does not cause any other problems... ?

--

the surprising part is the following:
this was a fresh / clean install of windows 10 pro (1909). with no custom vendor drivers whatsoever. in my case that graphics card came with a DELL Precision Tower 5810.
the graphics card driver is by microsoft (WHQL) - automatically installed by windows!
driver version 15.200.1045.0 - built in june 2015.

--

side note:
i was facing this problem (on RDP session) with one specific program, only.
it was P4V.exe (perforce windows client).
not sure why other programs would not show such symptoms ...

--

update:
recently i have installed an updated driver from the AMD web site (july 2021).
problem is gone :)

1
  • Thank you so much, i had the same problem (with Qt Creator) and a "Dell" AMD FirePro 2270. Last possible driver ist from 2017 - but your renaming solution worked...
    – Offler
    Jul 12, 2023 at 6:57
3

Simply disabled my Intel HD Graphics device via device manager on the remote computer, and restarted the application (NOT the remote computer).
Not sure why this issue happens......

1

I had the same error when opening Rstudio on remote desktop. I also tried the trick suggested by Opmet but it did not work for me. Seeing that the problem was related with the driver I simply updated them and this solved the problem in my case.

To do this, from the start menu you can open the Device Manager > Display Adapters > right-click > Update driver.

If already updated; Disable device and then Enable device again also solved the problem

#Image

I also found these forums that propose other solutions that might be helpful:
8 Ways to Fix Load­li­brary Failed with Error 87 in Win­dows 10
How to fix loadlibrary failed with error 87

0

On the RDP client side, you can manually opt for less demanding graphics parameters, like 24- or 16-bit colors, force "LAN" in the Experience tab, and uncheck the bitmap caching.

It'll be less satisfying from a visual point of view, but you should not have issues with graphical libraries not loading, because they won't sollicited in the first place.

1
  • Excuse me, but he will still have the problem with programs which use OpenGL....
    – Offler
    Jul 12, 2023 at 7:19
0

I have this problem when I open p4v sometimes.

Solution: Open Device Manager.

Right click and select Disable Device.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .