The vast majority of the windows I have open are maximized. How do I disable Windows 7/10 from moving windows when I accidentally drag the mouse cursor if they're already maximized? I want to keep the drag behavior as it already is when a window is in it's "restored" state however.

2 Answers 2


From vssher’s answers, after following the link to reach the desired registry keythis image here There is an option for “DragFromMaximize”, if you change the value to zero, you get the desired outcome.

Also there isn’t any necessary reason to change the drag width and height or drag sensitivity.

Works on both windows 7 & 10.

  • 1
    I can confirm it works on 10 at least and I'll try the tweak out on my 7 machines. Thank you very much! :-)
    – John
    Commented Jan 12, 2020 at 20:37
  • @John : Half the credit goes to vssher.
    – Valay_17
    Commented Jan 13, 2020 at 3:02
  • ...Up-voted his post. Thank you again.
    – John
    Commented Jan 14, 2020 at 1:48
  • 1
    @John : You are most welcome.
    – Valay_17
    Commented Jan 14, 2020 at 3:09
  • 1
    "DragFromMaximize" works very well in Windows 7 Professional also, thanks to you both, Valay_17 and John. I reset my DragHeight/Width to default values (4) and your right, Valay_17, you don't need to adjust those. Thanks!
    – vssher
    Commented Jan 14, 2020 at 12:04

HKEY_CURRENT_USER\Control Panel\Desktop

Edit the DragHeight and DragWidth in the Windows Registry to equal greater than the default of 4 pixels.

winhelponline.com says to change them to 50 pixels, this may be too many.

Source: https://www.winhelponline.com/blog/change-drag-drop-sensitivity-avoid-accidental-move-files/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .