9

Why are some 32 bit PNGs opened in Photoshop with Indexed Colors and no transparency?

For instance, I grabbed a png icon file of the Stack Overflow logo at: http://blog.stackoverflow.com/wp-content/uploads/icon-so.png When opening it in Photoshop CS3, it apparently treats it as indexed color and gets rid of the alpha channel. The image on the right is a screen grab of the icon. Changing the Image mode in Photoshop to RGB doesn't change the image at all. I've tried this with a few other PNGs and it seems hit or miss.

When viewed in other programs, it displays fine.

left:png opened in Photoshop, right:screen grab of png from browser

left:png opened in Photoshop, right:screen grab of png from browser

What gives?, does Photoshop not interpret the PNG file format correctly?

  • 1
    you can open this png in pixlr.com/editor and save, resulting png can be opened in photoshop – kreker Aug 14 '13 at 23:22
9

It looks like the problem is that Photoshop doesn't support part of the PNG-8 standard. PNG-8 like GIF uses a 256 color pallet. Both formats support using one of those 256 indexed colors to represent transparency, PNG-8 also supports setting an alpha-value for each of those 256 colors on the pallete. Photoshop (apparently CS3 and CS4) doesn't support this and renders every pixel opaque.

2

SuperPNG is able to correctly read this file.

0

Simple solution (in Photoshop CC):

Image -> Mode -> Check "RGB Color" (Not Indexed Color)

The file will now be editable as usual.

-1

There are two types of PNG files in common use. PNG8 uses indexed colors and has a single color for transparency, which means no alpha channel. PNG24 supports a separate alpha channel. The image you link to is a PNG8.

As for why Photoshop CS3 is mauling PNG8s so badly... that I don't know.

  • Photoshop CS4 is no better either, though Fireworks CS4 opens it perfectly. No clue what gives. – Darth Android Jun 12 '10 at 4:01
  • I guess it's good to know I'm not just doing something wrong :-) – Daniel Beardsley Jun 12 '10 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.