Platform: 2017 MacBook Pro, running macOS Catalina 10.15.2

Context: I had a pair of broken headphones where the right bud was much quieter than the left. So, I adjusted the volume settings on my MacBook to output more volume to the right to balance out the volume in my broken headphones. Now that I have a new pair, I adjusted the volume slider back to the center.

Problem: Sometimes my Mac will randomly revert back to outputting more volume to the right. Things that tend to trigger the reset include: when I wake it up from sleeping, plugging it in to charge, and unplugging headphones and plugging them back in. These actions do not always cause the reset, but they do frequently enough to the point where I need to go back in and manually change the volume balance back to the center multiple times per day.

Question: I've tried looking up solutions, to no avail - do you have any idea how I can finally get the damn thing to remember my volume settings? Can I just reset the volume settings to factory default or something? Manually fixing the volume balance again, and again, and again, every day, is really starting to get on my nerves. Any suggestions appreciated! Thanks!

7 Answers 7


I don't know what causes this, but I found and use https://www.tunabellysoftware.com/balance_lock/ which is free software to reset the balance when it goes off.

  • 3
    Thank you! I downloaded it from the Mac App Store and it is working as expected. Not sure why Apple can't just fix this bug on their own.... Jan 18, 2020 at 18:49
  • (Also, I don't have enough reputation for my upvote to count... not sure who downvoted this answer, but it did in fact work for me!) Jan 18, 2020 at 18:50
  • 2
    The engineer in me would love to know why... but in this context I am just a person who wants their computer to behave nicely
    – amacleod
    Dec 10, 2020 at 15:21
  • BalanceLock hang in notification area and does not allow to hide the icon. For me it's a show stopper. Apr 19, 2022 at 11:40

Had the same problem, when I centred the audio then changed volume it would drift to the right. I found going into the Audio Midi app, choosing the correct 2 channel audio out source (what ever the name of your headphones are but not the mic channel if you have one), change the format to 1 channel 16-bit integer, then change it back to 2 channel 32-bit again. After this the audio remained balanced.

  • I've used this trick over a week ago and it works. Balance didn't change since. Headphones - sony wh-1000xm3. macOs big sur 11.3.
    – dzh
    Apr 27, 2021 at 23:30
  • This trick worked for me. It seems it changes the balance when you enter the input mode and get back to only output mode.
    – Jonathan
    Dec 1, 2021 at 18:21
  • 2
    Tried this trick but it doesn't seem to lock the balance for me (macOS 12.1 / AirPods Pro)
    – vmallet
    Jan 26, 2022 at 17:24
  • MacOS 12.5.1 with Sony wh-1000xm4, the trick doesn't work. I can change the volume without losing the balance only if I do it in System Preferences>Sound, the balance shifts to the same point on the right as soon as I touch the volume control in the macOS menu bar.
    – Adi
    Sep 7, 2022 at 23:11

This happened while using a PHL 45bu6900ch monitor via USB audio.

Solution: reboot your mac while having the correct volume balance in system settings

system settings volume balance

This is much rather a workaround. It seems it is resetting the balance falsy when changing the volume. However resetting it to center is what we all want (99,999%). Be aware that the issue might reoccur.

Furthermore my balance was altered in different ways depending on how I changed volume.

  1. Using media buttons on keyboard -> Balance jitters around the center, not really noticeable, but you can see the slider jitter
  2. Using volume slider in the top bar -> It immediatly resets the balance to the "default" ( value of balance during last shutdown) volume slider in top bar
  3. Using the volume slider in system settings -> balance is not altered

I have never seen such an misbehaviour from apple products... This is almost microsoft quality 🤪


I've noticed that this will only happen when playing sounds from two different audio sources, such as two browser tabs playing sound simultaneously. I'm not sure as to why this is but I figured out that this was the cause in my case.


I suspect it's using the volume and balance from when it was last shutdown. My understanding is that, to change the volume of the power-on sound, you set your volume to the desired level, then use the GUI to power the macbook down. Doing that sets the volume in NVRAM so it knows what volume to use on bootup. It also likely saves other sound settings such as balance.

If you're like me, you seldom power down your macbook, preferring to use sleep or hibernation instead. You probably last powered it down via the GUI when your balance was off-center, and haven't done it since you replaced your headphones so it's still using that setting.


The issue seems to occur when increasing or decreasing volume over a multi-channel audio output device. Ideally the system should be changing the output value across all channels by the same amount. However, it seems to be distributing the change non-uniformly across the channels.

One can try the same on Audio Midi Setup(built-in) on mac.

I was looking for a solution that didn't involve some installation however @mmdl's solution doesn't seem to be working now. Tried on MacOS 12.6 with Sony wh-1000xm5.

@enviable's solution worked.

  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 21, 2022 at 15:33

When this happens try bouncing coreaudiod with

 ps aux | grep coreaudiod | grep -v grep | awk '{print $2}' | xargs sudo kill -9

Some background… I noticed that I had 2 active coreaudiod sound drivers which I could see with:

ps aux | grep coreaudiod

One was Boom3D and the other was Microsoft Teams. I've since uninstalled the Teams driver. I'll see if it comes back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .