When visiting a site with an invalid SSL certificate, Chrome displays an alert which says:

Your connection is not private

But it is still possible to proceed to the site by clicking "Advanced > Proceed to example.org (unsafe)", after which Chrome remembers the exception for this site (tested in Google Chrome Version 79.0.3945.117) for future sessions.

Now, it is possible to remove the exception for the current site by clicking the "Re-enable warnings" link from the address bar "Not secure" badge where a message like the following appears:

You have choosen to disable security warnings for this site. Re-enable warnings

But is it possible to "Re-enable warnings" for all sites, not only for the current one?.

  • You might wish to use the Chrome Enable HTTPS Everywhere Extension. chrome.google.com/webstore/detail/https-everywhere/…
    – John
    Jan 13, 2020 at 0:27
  • How could that extension allow me to restore Chrome warnings?. Jan 13, 2020 at 2:41
  • I read several articles on this subject. There were some registry change methods and I not like these. The article on extensions indicated it would restore security warnings which is why I suggested it.
    – John
    Jan 13, 2020 at 2:43

1 Answer 1

  1. Go the Chrome menu (three vertical dots top right corner)
  2. Settings
  3. Clear Browsing Data
  4. Switch from "Basic" to "Advanced" tab (important!)
  5. Tick "Browsing History"
  6. Press "Clear Data" Button

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .